28457ae6fe
* gnu/packages/gnome.scm (gnome-shell): Update to 3.34.2.
[source]: Add patch.
[native-inputs]: Add asciidoc.
[inputs]: Add gnome-autoar.
* gnu/packages/patches/gnome-shell-theme.patch: Adjust patch accordingly.
* gnu/packages/patches/gnome-shell-disable-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
(cherry picked from commit 4ac325aa9b
)
51 lines
2 KiB
Diff
51 lines
2 KiB
Diff
Adjust GNOME-Shell so that it uses a Guix theme by default.
|
|
|
|
Patch by Ludovic Courtès <ludo@gnu.org>.
|
|
|
|
diff -ur a/data/gnome-shell-theme.gresource.xml b/data/gnome-shell-theme.gresource.xml
|
|
--- a/data/gnome-shell-theme.gresource.xml 2019-12-11 15:06:31.000000000 -0500
|
|
+++ b/data/gnome-shell-theme.gresource.xml 2019-12-21 00:31:55.895866241 -0500
|
|
@@ -19,6 +19,8 @@
|
|
<file>no-events.svg</file>
|
|
<file>no-notifications.svg</file>
|
|
<file>noise-texture.png</file>
|
|
+ <file>guix-background.png</file>
|
|
+ <file>guix-logo.png</file>
|
|
<file>pad-osd.css</file>
|
|
<file alias="icons/pointer-double-click-symbolic.svg">pointer-double-click-symbolic.svg</file>
|
|
<file alias="icons/pointer-drag-symbolic.svg">pointer-drag-symbolic.svg</file>
|
|
diff -ur a/data/theme/gnome-shell-sass/_common.scss b/data/theme/gnome-shell-sass/_common.scss
|
|
--- a/data/theme/gnome-shell-sass/_common.scss 2019-12-11 15:06:31.000000000 -0500
|
|
+++ b/data/theme/gnome-shell-sass/_common.scss 2019-12-21 00:33:49.495832135 -0500
|
|
@@ -1994,7 +1994,16 @@
|
|
}
|
|
}
|
|
|
|
- .login-dialog-logo-bin { padding: 24px 0px; }
|
|
+ .login-dialog-logo-bin {
|
|
+ /* Make it a bit narrower than .login-dialog-user-list. */
|
|
+ width: 12em;
|
|
+ height: 8em;
|
|
+ background: url(resource:///org/gnome/shell/theme/guix-logo.png);
|
|
+ background-color: transparent;
|
|
+ background-repeat: no-repeat;
|
|
+ background-size: contain;
|
|
+ background-position: center; }
|
|
+
|
|
.login-dialog-banner { color: darken($osd_fg_color,10%); }
|
|
.login-dialog-button-box { spacing: 5px; }
|
|
.login-dialog-message-warning { color: $warning_color; }
|
|
@@ -2143,9 +2152,10 @@
|
|
}
|
|
|
|
#lockDialogGroup {
|
|
- background: lighten(#2e3436, 8%) url(resource:///org/gnome/shell/theme/noise-texture.png);
|
|
- background-repeat: repeat;
|
|
-}
|
|
+ background: lighten(#2e3436, 8%) url(resource:///org/gnome/shell/theme/guix-background.png);
|
|
+ background-repeat: no-repeat;
|
|
+ background-size: cover;
|
|
+ background-position: center; }
|
|
|
|
#screenShieldNotifications {
|
|
StButton#vhandle, StButton#hhandle {
|