gnu: gnome-shell: Update to 3.34.2.

* gnu/packages/gnome.scm (gnome-shell): Update to 3.34.2.
[source]: Add patch.
[native-inputs]: Add asciidoc.
[inputs]: Add gnome-autoar.
* gnu/packages/patches/gnome-shell-theme.patch: Adjust patch accordingly.
* gnu/packages/patches/gnome-shell-disable-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

(cherry picked from commit 4ac325aa9b)
This commit is contained in:
Kei Kebreau 2019-12-21 23:21:51 -05:00
parent 76e1830c03
commit 28457ae6fe
No known key found for this signature in database
GPG key ID: E6A5EE3C19467A0D
4 changed files with 47 additions and 20 deletions

View file

@ -1001,6 +1001,7 @@ dist_patch_DATA = \
%D%/packages/patches/gmp-arm-asm-nothumb.patch \
%D%/packages/patches/gmp-faulty-test.patch \
%D%/packages/patches/gnome-shell-theme.patch \
%D%/packages/patches/gnome-shell-disable-test.patch \
%D%/packages/patches/gnome-tweaks-search-paths.patch \
%D%/packages/patches/gnupg-default-pinentry.patch \
%D%/packages/patches/gnutls-skip-trust-store-test.patch \

View file

@ -7088,7 +7088,7 @@ (define-public gnome-control-center
(define-public gnome-shell
(package
(name "gnome-shell")
(version "3.32.2")
(version "3.34.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@ -7096,8 +7096,9 @@ (define-public gnome-shell
name "-" version ".tar.xz"))
(sha256
(base32
"0anlkdnqsp5fqvmg95rqjpp1ifcx5xzsvwcrdsvb1cqzbh6inmp5"))
(patches (search-patches "gnome-shell-theme.patch"))
"0k9vq2gh1nhdd6fpp7jnwx37qxaakawiqw1xnlfjvq5g5zdn8ckh"))
(patches (search-patches "gnome-shell-theme.patch"
"gnome-shell-disable-test.patch"))
(modules '((guix build utils)))
(snippet
#~(begin
@ -7191,7 +7192,8 @@ (define-public gnome-shell
'("inkscape" "intltool" "glib:bin"))
#:outputs outputs)))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
`(("asciidoc" ,asciidoc)
("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
("gobject-introspection" ,gobject-introspection)
("inkscape" ,inkscape)
@ -7212,6 +7214,7 @@ (define-public gnome-shell
("gdm" ,gdm)
("gdk-pixbuf" ,gdk-pixbuf+svg)
("gjs" ,gjs)
("gnome-autoar" ,gnome-autoar)
("gnome-bluetooth" ,gnome-bluetooth)
("gnome-desktop" ,gnome-desktop)
("gnome-settings-daemon" ,gnome-settings-daemon)

View file

@ -0,0 +1,25 @@
This test seems to require a D-Bus connection not available in the build
environment.
diff -ur /tmp/guix-build-gnome-shell-3.34.2.drv-0/gnome-shell-3.34.2/src/st/meson.build b/src/st/meson.build
--- /tmp/guix-build-gnome-shell-3.34.2.drv-0/gnome-shell-3.34.2/src/st/meson.build 1969-12-31 19:00:00.000000000 -0500
+++ b/src/st/meson.build 2019-12-23 00:46:14.721198022 -0500
@@ -132,18 +132,6 @@
sources: st_enums[1]
)
-test_theme = executable('test-theme',
- sources: 'test-theme.c',
- c_args: st_cflags,
- dependencies: [mutter_dep, gtk_dep],
- build_rpath: mutter_typelibdir,
- link_with: libst
-)
-
-test('CSS styling support', test_theme,
- workdir: meson.current_source_dir()
-)
-
libst_gir = gnome.generate_gir(libst,
sources: st_gir_sources,
nsversion: '1.0',

View file

@ -2,25 +2,23 @@ Adjust GNOME-Shell so that it uses a Guix theme by default.
Patch by Ludovic Courtès <ludo@gnu.org>.
diff --git a/data/gnome-shell-theme.gresource.xml b/data/gnome-shell-theme.gresource.xml
index 76aeaa5..8eaf32e 100644
--- a/data/gnome-shell-theme.gresource.xml
+++ b/data/gnome-shell-theme.gresource.xml
@@ -22,6 +22,8 @@
diff -ur a/data/gnome-shell-theme.gresource.xml b/data/gnome-shell-theme.gresource.xml
--- a/data/gnome-shell-theme.gresource.xml 2019-12-11 15:06:31.000000000 -0500
+++ b/data/gnome-shell-theme.gresource.xml 2019-12-21 00:31:55.895866241 -0500
@@ -19,6 +19,8 @@
<file>no-events.svg</file>
<file>no-notifications.svg</file>
<file>noise-texture.png</file>
+ <file>guix-background.png</file>
+ <file>guix-logo.png</file>
<file>pad-osd.css</file>
<file>page-indicator-active.svg</file>
<file>page-indicator-inactive.svg</file>
diff --git a/data/theme/gnome-shell-sass/_common.scss b/data/theme/gnome-shell-sass/_common.scss
index 54d9f39..b9badd0 100644
--- a/data/theme/gnome-shell-sass/_common.scss
+++ b/data/theme/gnome-shell-sass/_common.scss
@@ -1742,7 +1742,16 @@ $legacy_icon_size: 24px;
<file alias="icons/pointer-double-click-symbolic.svg">pointer-double-click-symbolic.svg</file>
<file alias="icons/pointer-drag-symbolic.svg">pointer-drag-symbolic.svg</file>
diff -ur a/data/theme/gnome-shell-sass/_common.scss b/data/theme/gnome-shell-sass/_common.scss
--- a/data/theme/gnome-shell-sass/_common.scss 2019-12-11 15:06:31.000000000 -0500
+++ b/data/theme/gnome-shell-sass/_common.scss 2019-12-21 00:33:49.495832135 -0500
@@ -1994,7 +1994,16 @@
}
}
- .login-dialog-logo-bin { padding: 24px 0px; }
@ -37,14 +35,14 @@ index 54d9f39..b9badd0 100644
.login-dialog-banner { color: darken($osd_fg_color,10%); }
.login-dialog-button-box { spacing: 5px; }
.login-dialog-message-warning { color: $warning_color; }
@@ -1889,9 +1898,10 @@ $legacy_icon_size: 24px;
@@ -2143,9 +2152,10 @@
}
#lockDialogGroup {
- background: #2e3436 url(resource:///org/gnome/shell/theme/noise-texture.png);
- background: lighten(#2e3436, 8%) url(resource:///org/gnome/shell/theme/noise-texture.png);
- background-repeat: repeat;
-}
+ background: #2e3436 url(resource:///org/gnome/shell/theme/guix-background.png);
+ background: lighten(#2e3436, 8%) url(resource:///org/gnome/shell/theme/guix-background.png);
+ background-repeat: no-repeat;
+ background-size: cover;
+ background-position: center; }