76454d9af3
* gnu/packages/cmake.scm (cmake): Update to 3.24.2. [source]: Adjust snippet to preserve "Utilities/cmelf". Override with new patch. [native-inputs]: Use modify-inputs and remove labels. * gnu/packages/patches/cmake-curl-certificates-3.24.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
21 lines
1.1 KiB
Diff
21 lines
1.1 KiB
Diff
Submitted upstream at https://gitlab.kitware.com/cmake/cmake/-/merge_requests/7670.
|
|
|
|
diff --git a/Source/cmCurl.cxx b/Source/cmCurl.cxx
|
|
index 28ee24dfe9..fc5405213a 100644
|
|
--- a/Source/cmCurl.cxx
|
|
+++ b/Source/cmCurl.cxx
|
|
@@ -38,6 +38,14 @@ std::string cmCurlSetCAInfo(::CURL* curl, const std::string& cafile)
|
|
::CURLcode res = ::curl_easy_setopt(curl, CURLOPT_CAINFO, cafile.c_str());
|
|
check_curl_result(res, "Unable to set TLS/SSL Verify CAINFO: ");
|
|
}
|
|
+ /* Honor the user-configurable OpenSSL environment variables. */
|
|
+ else if (cmSystemTools::GetEnv("SSL_CERT_FILE", e)) {
|
|
+ ::CURLcode res = ::curl_easy_setopt(curl, CURLOPT_CAINFO, e.c_str());
|
|
+ check_curl_result(res, "Unable to set TLS/SSL Verify CAINFO: ");
|
|
+ } else if (cmSystemTools::GetEnv("SSL_CERT_DIR", e)) {
|
|
+ ::CURLcode res = ::curl_easy_setopt(curl, CURLOPT_CAPATH, e.c_str());
|
|
+ check_curl_result(res, "Unable to set TLS/SSL Verify CAINFO: ");
|
|
+ }
|
|
#ifdef CMAKE_FIND_CAFILE
|
|
# define CMAKE_CAFILE_FEDORA "/etc/pki/tls/certs/ca-bundle.crt"
|
|
else if (cmSystemTools::FileExists(CMAKE_CAFILE_FEDORA, true)) {
|