19e1f12ce4
Print a more helpful error message when someone attempts to run Telega on an incompatible Emacs (e.g a 32-bit Emacs without wide ints). * gnu/packages/patches/emacs-telega-test-env.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/emacs-xyz.scm (emacs-telega)[source]: Use it. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
14 lines
381 B
Diff
14 lines
381 B
Diff
Test Emacs environment on startup.
|
|
|
|
Patch by Diego N. Barbato
|
|
|
|
--- a/telega.el 2020-02-07 17:07:18.549970090 +0100
|
|
+++ b/telega.el 2020-02-07 17:10:08.383499765 +0100
|
|
@@ -82,6 +82,7 @@
|
|
"Start telegramming.
|
|
If prefix ARG is given, then will not pop to telega root buffer."
|
|
(interactive "P")
|
|
+ (telega-test-env t)
|
|
(telega--create-hier)
|
|
|
|
(unless (telega-server-live-p)
|