gnu: emacs-telega: Test Emacs environment on startup.

Print a more helpful error message when someone attempts to run Telega on an
incompatible Emacs (e.g a 32-bit Emacs without wide ints).

* gnu/packages/patches/emacs-telega-test-env.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/emacs-xyz.scm (emacs-telega)[source]: Use it.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
This commit is contained in:
Diego Nicola Barbato 2020-02-07 17:59:31 +01:00 committed by Efraim Flashner
parent a663b7040c
commit 19e1f12ce4
No known key found for this signature in database
GPG key ID: 41AAE7DCCA3D8351
3 changed files with 16 additions and 0 deletions

View file

@ -864,6 +864,7 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-magit-log-format-author-margin.patch \
%D%/packages/patches/emacs-scheme-complete-scheme-r5rs-info.patch \
%D%/packages/patches/emacs-source-date-epoch.patch \
%D%/packages/patches/emacs-telega-test-env.patch \
%D%/packages/patches/emacs-undohist-ignored.patch \
%D%/packages/patches/emacs-wordnut-require-adaptive-wrap.patch \
%D%/packages/patches/emacs-zones-called-interactively.patch \

View file

@ -21376,6 +21376,7 @@ (define-public emacs-telega
(sha256
(base32
"0mv6i80958d9crzspzik5xh5g8326115bvg2frgv0dp9p6rm86m3"))
(patches (search-patches "emacs-telega-test-env.patch"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments

View file

@ -0,0 +1,14 @@
Test Emacs environment on startup.
Patch by Diego N. Barbato
--- a/telega.el 2020-02-07 17:07:18.549970090 +0100
+++ b/telega.el 2020-02-07 17:10:08.383499765 +0100
@@ -82,6 +82,7 @@
"Start telegramming.
If prefix ARG is given, then will not pop to telega root buffer."
(interactive "P")
+ (telega-test-env t)
(telega--create-hier)
(unless (telega-server-live-p)