guix/gnu/packages/patches/tpetra-remove-duplicate-using.patch
Paul A. Patience fed6ac2ae1
gnu: trilinos-for-dealii-openmpi: Fix build.
This fixes the error

  error: ‘std::hypot’ has not been declared

caused by using an older version of gcc, but requires some patches to
placate newer versions of gcc.

* gnu/packages/maths.scm (trilinos-for-dealii-openmpi)[origin]: Add
patches.
[native-inputs]: Remove gcc-7.
* gnu/packages/patches/teuchos-remove-duplicate-using.patch: New file.
* gnu/packages/patches/tpetra-remove-duplicate-using.patch: Likewise.
* gnu/local.mk (dist_patch_DATA): Register them.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2023-10-21 00:27:26 +02:00

19 lines
929 B
Diff

commit 919ceb0acbf4c6bc4f463433504a338c643612c2
Author: Karen D. Devine <kddevin@sandia.gov>
Date: Tue Feb 2 13:49:13 2021 -0700
tpetra: removed duplicate using statement #8673
diff --git a/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp b/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp
index a76f78c41a8..69d4dc46d03 100644
--- a/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp
+++ b/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp
@@ -1094,7 +1094,6 @@ init (const keys_type& keys,
// Allocate the array of (key,value) pairs. Don't fill it with
// zeros, because we will fill it with actual data below.
- using Kokkos::ViewAllocateWithoutInitializing;
typedef typename val_type::non_const_type nonconst_val_type;
nonconst_val_type val (ViewAllocateWithoutInitializing ("Tpetra::FixedHashTable::pairs"),
theNumKeys);