guix/gnu/packages/patches/teuchos-remove-duplicate-using.patch
Paul A. Patience fed6ac2ae1
gnu: trilinos-for-dealii-openmpi: Fix build.
This fixes the error

  error: ‘std::hypot’ has not been declared

caused by using an older version of gcc, but requires some patches to
placate newer versions of gcc.

* gnu/packages/maths.scm (trilinos-for-dealii-openmpi)[origin]: Add
patches.
[native-inputs]: Remove gcc-7.
* gnu/packages/patches/teuchos-remove-duplicate-using.patch: New file.
* gnu/packages/patches/tpetra-remove-duplicate-using.patch: Likewise.
* gnu/local.mk (dist_patch_DATA): Register them.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2023-10-21 00:27:26 +02:00

35 lines
1.2 KiB
Diff

commit e27d9ae98502626d8407045a4e082797682ba56b
Author: Christian Glusa <caglusa@sandia.gov>
Date: Fri Jul 3 18:02:27 2020 -0600
Teuchos Comm test: remove duplicate 'using ...'
diff --git a/packages/teuchos/comm/test/Comm/reduce.cpp b/packages/teuchos/comm/test/Comm/reduce.cpp
index c05ebc0dc34..eac1975ef83 100644
--- a/packages/teuchos/comm/test/Comm/reduce.cpp
+++ b/packages/teuchos/comm/test/Comm/reduce.cpp
@@ -53,9 +53,6 @@ bool
testReduceSum (bool& success, std::ostream& out,
const int root, const Teuchos::Comm<int>& comm)
{
-#ifdef HAVE_TEUCHOS_MPI
- using Teuchos::MpiComm;
-#endif // HAVE_TEUCHOS_MPI
using Teuchos::reduce;
using Teuchos::TypeNameTraits;
using std::endl;
diff --git a/packages/teuchos/comm/test/Comm/scatter.cpp b/packages/teuchos/comm/test/Comm/scatter.cpp
index 0ca961d2846..001009029c4 100644
--- a/packages/teuchos/comm/test/Comm/scatter.cpp
+++ b/packages/teuchos/comm/test/Comm/scatter.cpp
@@ -53,9 +53,6 @@ bool
testScatter (bool& success, std::ostream& out,
const int root, const Teuchos::Comm<int>& comm)
{
-#ifdef HAVE_TEUCHOS_MPI
- using Teuchos::MpiComm;
-#endif // HAVE_TEUCHOS_MPI
using Teuchos::scatter;
using Teuchos::TypeNameTraits;
using std::endl;