9f2c5e901e
* gnu/packages/patches/zig-disable-libc-note-test.patch, gnu/packages/patches/zig-use-system-paths.patch: New files. * gnu/packages/zig.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES, dist_patch_DATA): Adjust accordingly.
31 lines
1.3 KiB
Diff
31 lines
1.3 KiB
Diff
This test fails with "error.CompilationIncorrectlySucceeded".
|
|
|
|
diff --git a/test/compile_errors.zig b/test/compile_errors.zig
|
|
index fd1255c..20d5548 100644
|
|
--- a/test/compile_errors.zig
|
|
+++ b/test/compile_errors.zig
|
|
@@ -2751,15 +2751,15 @@ pub fn addCases(cases: *tests.CompileErrorContext) void {
|
|
"tmp.zig:3:5: error: dependency on libc must be explicitly specified in the build command",
|
|
});
|
|
|
|
- cases.addTest("libc headers note",
|
|
- \\const c = @cImport(@cInclude("stdio.h"));
|
|
- \\export fn entry() void {
|
|
- \\ _ = c.printf("hello, world!\n");
|
|
- \\}
|
|
- , &[_][]const u8{
|
|
- "tmp.zig:1:11: error: C import failed",
|
|
- "tmp.zig:1:11: note: libc headers not available; compilation does not link against libc",
|
|
- });
|
|
+// cases.addTest("libc headers note",
|
|
+// \\const c = @cImport(@cInclude("stdio.h"));
|
|
+// \\export fn entry() void {
|
|
+// \\ _ = c.printf("hello, world!\n");
|
|
+// \\}
|
|
+// , &[_][]const u8{
|
|
+// "tmp.zig:1:11: error: C import failed",
|
|
+// "tmp.zig:1:11: note: libc headers not available; compilation does not link against libc",
|
|
+// });
|
|
}
|
|
|
|
cases.addTest("comptime vector overflow shows the index",
|