gnu: Add zig.

* gnu/packages/patches/zig-disable-libc-note-test.patch,
gnu/packages/patches/zig-use-system-paths.patch: New files.
* gnu/packages/zig.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES, dist_patch_DATA): Adjust accordingly.
This commit is contained in:
Liliana Marie Prikler 2021-09-09 15:32:22 +02:00
parent 84c6f17f16
commit 9f2c5e901e
No known key found for this signature in database
GPG Key ID: 442A84B8C70E2F87
4 changed files with 281 additions and 0 deletions

View File

@ -610,6 +610,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/xdisorg.scm \
%D%/packages/xorg.scm \
%D%/packages/xfce.scm \
%D%/packages/zig.scm \
%D%/packages/zile.scm \
%D%/packages/zwave.scm \
\
@ -1943,6 +1944,8 @@ dist_patch_DATA = \
%D%/packages/patches/ytfzf-updates.patch \
%D%/packages/patches/ytnef-CVE-2021-3403.patch \
%D%/packages/patches/ytnef-CVE-2021-3404.patch \
%D%/packages/patches/zig-disable-libc-note-test.patch \
%D%/packages/patches/zig-use-system-paths.patch \
%D%/packages/patches/zstd-CVE-2021-24031_CVE-2021-24032.patch \
%D%/packages/patches/zziplib-CVE-2018-16548.patch

View File

@ -0,0 +1,31 @@
This test fails with "error.CompilationIncorrectlySucceeded".
diff --git a/test/compile_errors.zig b/test/compile_errors.zig
index fd1255c..20d5548 100644
--- a/test/compile_errors.zig
+++ b/test/compile_errors.zig
@@ -2751,15 +2751,15 @@ pub fn addCases(cases: *tests.CompileErrorContext) void {
"tmp.zig:3:5: error: dependency on libc must be explicitly specified in the build command",
});
- cases.addTest("libc headers note",
- \\const c = @cImport(@cInclude("stdio.h"));
- \\export fn entry() void {
- \\ _ = c.printf("hello, world!\n");
- \\}
- , &[_][]const u8{
- "tmp.zig:1:11: error: C import failed",
- "tmp.zig:1:11: note: libc headers not available; compilation does not link against libc",
- });
+// cases.addTest("libc headers note",
+// \\const c = @cImport(@cInclude("stdio.h"));
+// \\export fn entry() void {
+// \\ _ = c.printf("hello, world!\n");
+// \\}
+// , &[_][]const u8{
+// "tmp.zig:1:11: error: C import failed",
+// "tmp.zig:1:11: note: libc headers not available; compilation does not link against libc",
+// });
}
cases.addTest("comptime vector overflow shows the index",

View File

@ -0,0 +1,143 @@
This patch replaces the OS-specific detection mechanism by one that solely
relies on environment variables. This has the benefit that said environment
variables can be used as search paths in Guix.
Index: zig-0.8.1/lib/std/zig/system.zig
===================================================================
--- zig-0.8.1.orig/lib/std/zig/system.zig
+++ zig-0.8.1/lib/std/zig/system.zig
@@ -39,101 +39,57 @@ pub const NativePaths = struct {
};
errdefer self.deinit();
- var is_nix = false;
- if (process.getEnvVarOwned(allocator, "NIX_CFLAGS_COMPILE")) |nix_cflags_compile| {
- defer allocator.free(nix_cflags_compile);
-
- is_nix = true;
- var it = mem.tokenize(nix_cflags_compile, " ");
+ // TODO: Support cross-compile paths?
+ if (process.getEnvVarOwned(allocator, "C_INCLUDE_PATH")) |c_include_path| {
+ defer allocator.free(c_include_path);
+ var it = mem.tokenize(c_include_path, ":");
while (true) {
- const word = it.next() orelse break;
- if (mem.eql(u8, word, "-isystem")) {
- const include_path = it.next() orelse {
- try self.addWarning("Expected argument after -isystem in NIX_CFLAGS_COMPILE");
- break;
- };
- try self.addIncludeDir(include_path);
- } else {
- if (mem.startsWith(u8, word, "-frandom-seed=")) {
- continue;
- }
- try self.addWarningFmt("Unrecognized C flag from NIX_CFLAGS_COMPILE: {s}", .{word});
- }
+ const dir = it.next() orelse break;
+ try self.addIncludeDir(dir);
}
} else |err| switch (err) {
error.InvalidUtf8 => {},
error.EnvironmentVariableNotFound => {},
error.OutOfMemory => |e| return e,
}
- if (process.getEnvVarOwned(allocator, "NIX_LDFLAGS")) |nix_ldflags| {
- defer allocator.free(nix_ldflags);
- is_nix = true;
- var it = mem.tokenize(nix_ldflags, " ");
+ if (process.getEnvVarOwned(allocator, "CPLUS_INCLUDE_PATH")) |cplus_include_path| {
+ defer allocator.free(cplus_include_path);
+ var it = mem.tokenize(cplus_include_path, ":");
while (true) {
- const word = it.next() orelse break;
- if (mem.eql(u8, word, "-rpath")) {
- const rpath = it.next() orelse {
- try self.addWarning("Expected argument after -rpath in NIX_LDFLAGS");
- break;
- };
- try self.addRPath(rpath);
- } else if (word.len > 2 and word[0] == '-' and word[1] == 'L') {
- const lib_path = word[2..];
- try self.addLibDir(lib_path);
- } else {
- try self.addWarningFmt("Unrecognized C flag from NIX_LDFLAGS: {s}", .{word});
- break;
- }
+ const dir = it.next() orelse break;
+ try self.addIncludeDir(dir);
}
} else |err| switch (err) {
error.InvalidUtf8 => {},
error.EnvironmentVariableNotFound => {},
error.OutOfMemory => |e| return e,
}
- if (is_nix) {
- return self;
- }
-
- if (comptime Target.current.isDarwin()) {
- try self.addIncludeDir("/usr/include");
- try self.addIncludeDir("/usr/local/include");
- try self.addLibDir("/usr/lib");
- try self.addLibDir("/usr/local/lib");
-
- try self.addFrameworkDir("/Library/Frameworks");
- try self.addFrameworkDir("/System/Library/Frameworks");
-
- return self;
+ if (process.getEnvVarOwned(allocator, "LIBRARY_PATH")) |library_path| {
+ defer allocator.free(library_path);
+ var it = mem.tokenize(library_path, ":");
+ while (true) {
+ const dir = it.next() orelse break;
+ try self.addLibDir(dir);
+ }
+ } else |err| switch (err) {
+ error.InvalidUtf8 => {},
+ error.EnvironmentVariableNotFound => {},
+ error.OutOfMemory => |e| return e,
}
- if (native_target.os.tag != .windows) {
- const triple = try native_target.linuxTriple(allocator);
- const qual = native_target.cpu.arch.ptrBitWidth();
-
- // TODO: $ ld --verbose | grep SEARCH_DIR
- // the output contains some paths that end with lib64, maybe include them too?
- // TODO: what is the best possible order of things?
- // TODO: some of these are suspect and should only be added on some systems. audit needed.
-
- try self.addIncludeDir("/usr/local/include");
- try self.addLibDirFmt("/usr/local/lib{d}", .{qual});
- try self.addLibDir("/usr/local/lib");
-
- try self.addIncludeDirFmt("/usr/include/{s}", .{triple});
- try self.addLibDirFmt("/usr/lib/{s}", .{triple});
-
- try self.addIncludeDir("/usr/include");
- try self.addLibDirFmt("/lib{d}", .{qual});
- try self.addLibDir("/lib");
- try self.addLibDirFmt("/usr/lib{d}", .{qual});
- try self.addLibDir("/usr/lib");
-
- // example: on a 64-bit debian-based linux distro, with zlib installed from apt:
- // zlib.h is in /usr/include (added above)
- // libz.so.1 is in /lib/x86_64-linux-gnu (added here)
- try self.addLibDirFmt("/lib/{s}", .{triple});
+ if (process.getEnvVarOwned(allocator, "DYLD_FRAMEWORK_PATH")) |dyld_framework_path| {
+ defer allocator.free(dyld_framework_path);
+ var it = mem.tokenize(dyld_framework_path, ":");
+ while (true) {
+ const dir = it.next() orelse break;
+ try self.addFrameworkDir(dir);
+ }
+ } else |err| switch (err) {
+ error.InvalidUtf8 => {},
+ error.EnvironmentVariableNotFound => {},
+ error.OutOfMemory => |e| return e,
}
return self;

104
gnu/packages/zig.scm Normal file
View File

@ -0,0 +1,104 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2021 Liliana Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages zig)
#:use-module (guix packages)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system cmake)
#:use-module (gnu packages)
#:use-module (gnu packages llvm))
(define-public zig
(package
(name "zig")
(version "0.8.1")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/ziglang/zig.git")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32 "147qx7xgj0r353wh5ragzn6kmm1vrf31i8038z3zqwjnqqgqxi6c"))
(patches
(search-patches
"zig-disable-libc-note-test.patch"
"zig-use-system-paths.patch"))))
(build-system cmake-build-system)
(inputs
`(("clang" ,clang-12) ; Clang propagates llvm.
("lld" ,lld)))
;; Zig compiles fine with GCC, but also needs native LLVM libraries.
(native-inputs
`(("llvm" ,llvm-12)))
(arguments
`(#:configure-flags
(list ,@(if (%current-target-system)
(string-append "-DZIG_TARGET_TRIPLE="
(%current-target-system))
'()))
#:out-of-source? #f ; for tests
#:phases
(modify-phases %standard-phases
(add-after 'configure 'set-cache-dir
(lambda _
;; Set cache dir, otherwise Zig looks for `$HOME/.cache'.
(setenv "ZIG_GLOBAL_CACHE_DIR"
(string-append (getcwd) "/zig-cache"))))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key outputs tests? #:allow-other-keys)
(when tests?
(invoke (string-append (assoc-ref outputs "out") "/bin/zig")
;; Testing the standard library takes >7.5GB RAM, and
;; will fail if it is OOM-killed. The 'test-toolchain'
;; target skips standard library and doc tests.
"build" "test-toolchain"
;; Stage 2 is experimental, not what we run with `zig',
;; and stage 2 tests require a lot of RAM.
"-Dskip-stage2-tests"
;; Non-native tests try to link and execute non-native
;; binaries.
"-Dskip-non-native")))))))
(native-search-paths
(list
(search-path-specification
(variable "C_INCLUDE_PATH")
(files '("include")))
(search-path-specification
(variable "CPLUS_INCLUDE_PATH")
(files '("include/c++" "include")))
(search-path-specification
(variable "LIBRARY_PATH")
(files '("lib" "lib64")))))
(synopsis "General purpose programming language and toolchain")
(description "Zig is a general-purpose programming language and
toolchain. Among other features it provides
@itemize
@item an Optional type instead of null pointers,
@item manual memory management,
@item generic data structures and functions,
@item compile-time reflection and compile-time code execution,
@item integration with C using zig as a C compiler, and
@item concurrency via async functions.
@end itemize")
(home-page "https://github.com/ziglang/zig")
(license license:expat)))