gnu: bees: Update to 0.9.2.

* gnu/packages/file-systems.scm (bees): Update to 0.9.2.
[license]: Add two individual licences.
* gnu/packages/patches/bees-beesd-honor-destdir-on-installation.patch:
Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
This commit is contained in:
Morgan Smith 2023-02-12 13:12:56 -05:00 committed by Tobias Geerinckx-Rice
parent 1eea158ee5
commit 4f08551a83
No known key found for this signature in database
GPG Key ID: 0DB0FF884F556D79
3 changed files with 7 additions and 50 deletions

View File

@ -941,7 +941,6 @@ dist_patch_DATA = \
%D%/packages/patches/bsd-games-prevent-name-collisions.patch \ %D%/packages/patches/bsd-games-prevent-name-collisions.patch \
%D%/packages/patches/bsd-games-stdio.h.patch \ %D%/packages/patches/bsd-games-stdio.h.patch \
%D%/packages/patches/beancount-disable-googleapis-fonts.patch \ %D%/packages/patches/beancount-disable-googleapis-fonts.patch \
%D%/packages/patches/bees-beesd-honor-destdir-on-installation.patch \
%D%/packages/patches/beignet-correct-file-names.patch \ %D%/packages/patches/beignet-correct-file-names.patch \
%D%/packages/patches/bidiv-update-fribidi.patch \ %D%/packages/patches/bidiv-update-fribidi.patch \
%D%/packages/patches/binutils-2.37-file-descriptor-leak.patch \ %D%/packages/patches/binutils-2.37-file-descriptor-leak.patch \

View File

@ -1809,7 +1809,7 @@ in FUSE for rootless containers.")
(define-public bees (define-public bees
(package (package
(name "bees") (name "bees")
(version "0.8") (version "0.9.2")
(source (origin (source (origin
(method git-fetch) (method git-fetch)
(uri (git-reference (uri (git-reference
@ -1826,14 +1826,9 @@ in FUSE for rootless containers.")
(("city.o.*") "")) (("city.o.*") ""))
(substitute* "src/bees-hash.cc" (substitute* "src/bees-hash.cc"
(("#include .crucible/city.h.") "#include <city.h>")))) (("#include .crucible/city.h.") "#include <city.h>"))))
(patches
(search-patches
;; XXX: Cherry-picked from upstream, remove the patch when
;; bumping version.
"bees-beesd-honor-destdir-on-installation.patch"))
(sha256 (sha256
(base32 (base32
"1kxpz1p9k5ir385kpvmfjawki5vg22hlx768k7835w6n5z5a65y4")))) "0xik1xg6ma5yglhvs60ny27242iapqwzikmqbgij1avjffs6776a"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments (arguments
(list #:test-target "test" (list #:test-target "test"
@ -1867,7 +1862,8 @@ in FUSE for rootless containers.")
(search-input-file inputs (string-append "/bin/" command))) (search-input-file inputs (string-append "/bin/" command)))
(("btrfs sub") (("btrfs sub")
(string-append (search-input-file inputs "/bin/btrfs") " sub")))))))) (string-append (search-input-file inputs "/bin/btrfs")
" sub"))))))))
(inputs (list btrfs-progs cityhash util-linux)) (inputs (list btrfs-progs cityhash util-linux))
(home-page "https://github.com/Zygo/bees") (home-page "https://github.com/Zygo/bees")
(synopsis "Best-Effort Extent-Same, a btrfs dedupe agent") (synopsis "Best-Effort Extent-Same, a btrfs dedupe agent")
@ -1876,7 +1872,9 @@ in FUSE for rootless containers.")
for large btrfs filesystems. It is an offline dedupe combined with an for large btrfs filesystems. It is an offline dedupe combined with an
incremental data scan capability to minimize time data spends on disk from incremental data scan capability to minimize time data spends on disk from
write to dedupe.") write to dedupe.")
(license license:gpl3+))) (license (list license:gpl3+ ; the combined work
license:zlib ; lib/crc64.cc
license:gpl2)))) ; include/crucible/btrfs.h
(define-public dwarfs (define-public dwarfs
(package (package

View File

@ -1,40 +0,0 @@
From 66b00f8a972ebb4da68f7aa0d0656f43ce2a2c3a Mon Sep 17 00:00:00 2001
From: Hilton Chain <hako@ultrarare.space>
Date: Fri, 23 Dec 2022 11:04:46 +0800
Subject: [PATCH] beesd: Honor DESTDIR on installation.
Co-authored-by: Adam Faiz <adam.faiz@disroot.org>
Signed-off-by: Hilton Chain <hako@ultrarare.space>
---
Defines.mk | 1 +
scripts/beesd.in | 2 +-
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/Defines.mk b/Defines.mk
index 9e8df40..e5394ba 100644
--- a/Defines.mk
+++ b/Defines.mk
@@ -2,6 +2,7 @@ MAKE += PREFIX=$(PREFIX) LIBEXEC_PREFIX=$(LIBEXEC_PREFIX) ETC_PREFIX=$(ETC_PREFI
define TEMPLATE_COMPILER =
sed $< >$@ \
+ -e's#@DESTDIR@#$(DESTDIR)#' \
-e's#@PREFIX@#$(PREFIX)#' \
-e's#@ETC_PREFIX@#$(ETC_PREFIX)#' \
-e's#@LIBEXEC_PREFIX@#$(LIBEXEC_PREFIX)#'
diff --git a/scripts/beesd.in b/scripts/beesd.in
index 174bb6c..35d04aa 100755
--- a/scripts/beesd.in
+++ b/scripts/beesd.in
@@ -15,7 +15,7 @@ readonly AL128K="$((128*1024))"
readonly AL16M="$((16*1024*1024))"
readonly CONFIG_DIR=@ETC_PREFIX@/bees/
-readonly bees_bin=$(realpath @LIBEXEC_PREFIX@/bees)
+readonly bees_bin=$(realpath @DESTDIR@/@LIBEXEC_PREFIX@/bees)
command -v "$bees_bin" &> /dev/null || ERRO "Missing 'bees' agent"
--
2.38.1