gnu: emacs-debbugs: Fix build.

The current release already contains the changes.

* gnu/packages/emacs-xyz.scm (emacs-debbugs)[source]: Remove patch.
* gnu/packages/patches/emacs-debbugs-keep-patch-subject.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Unregister it.

Change-Id: Id51e6c9dec138721d288be28cd1c5e954d3228a9
This commit is contained in:
Hilton Chain 2023-11-09 12:59:34 +08:00
parent fb65b2c243
commit afce101047
No known key found for this signature in database
GPG Key ID: ACC66D09CA528292
3 changed files with 1 additions and 32 deletions

View File

@ -1097,7 +1097,6 @@ dist_patch_DATA = \
%D%/packages/patches/elm-reactor-static-files.patch \
%D%/packages/patches/elogind-fix-rpath.patch \
%D%/packages/patches/emacs-all-the-icons-remove-duplicate-rs.patch \
%D%/packages/patches/emacs-debbugs-keep-patch-subject.patch \
%D%/packages/patches/emacs-deferred-fix-number-of-arguments.patch \
%D%/packages/patches/emacs-elpy-dup-test-name.patch \
%D%/packages/patches/emacs-exec-path.patch \

View File

@ -8807,8 +8807,7 @@ by a query, so both a link can refer to several mails.")
(uri (string-append "https://elpa.gnu.org/packages/debbugs-"
version ".tar"))
(sha256
(base32 "0xj0sv5d3y88fsbm7yhm0v59mzj1srxayng1hr418v89ky43rxpr"))
(patches (search-patches "emacs-debbugs-keep-patch-subject.patch"))))
(base32 "0xj0sv5d3y88fsbm7yhm0v59mzj1srxayng1hr418v89ky43rxpr"))))
(build-system emacs-build-system)
(arguments '(#:include '("\\.el$" "\\.wsdl$" "\\.info$")))
(propagated-inputs

View File

@ -1,29 +0,0 @@
Preserve subject when replying to patch threads.
Upstream status: likely to be in the next release (bug#66330)
diff --git a/debbugs-gnu.el b/debbugs-gnu.el
index f366fba11d..cd549e364d 100644
--- a/debbugs-gnu.el
+++ b/debbugs-gnu.el
@@ -1747,6 +1747,12 @@ MERGED is the list of bugs merged with this one."
(format "Re: bug#%d: %s" id (alist-get 'subject status)))
(debbugs-gnu-summary-mode 1)))
+(defcustom debbugs-gnu-summary-keep-subject
+ (rx "[PATCH" (? (0+ (not (any digit "/]"))) (1+ digit) "/" (1+ digit)) "]")
+ "Regular expression which keeps the original message subject in replies."
+ :version "29.1"
+ :type 'regexp)
+
(defvar debbugs-gnu-summary-mode-map
(let ((map (make-sparse-keymap)))
(define-key map "C" #'debbugs-gnu-send-control-message)
@@ -1778,6 +1784,8 @@ MERGED is the list of bugs merged with this one."
(cons new new))
address))))))
,@(and debbugs-gnu-subject
+ (not (string-match-p debbugs-gnu-summary-keep-subject
+ debbugs-gnu-subject))
`((subject ,debbugs-gnu-subject)))))))
(defun debbugs-gnu-guess-current-id ()