mirror of
https://codeberg.org/mtxyz/nixconf.git
synced 2024-11-12 19:32:35 +00:00
Bailey Stevens
0ac0c6dda1
Flake lock file updates: • Updated input 'edge': 'github:nixos/nixpkgs/e55a24ef5a32575c77aab64bd6310fa455c609c2?narHash=sha256-njn2GjAgxxAQ1PL5F2qPuJukhJ1Ltrgf9mGjOYQp0g8%3D' (2024-08-10) → 'github:nixos/nixpkgs/9ae7e3865a7e975139c3e1088c96c983906b2fef?narHash=sha256-J2Oq60mv0VbG6YEhFBHHo%2BEdUHN8QuGdKLct5kmC8RQ%3D' (2024-08-30) • Updated input 'home-manager': 'github:nix-community/home-manager/b3d5ea65d88d67d4ec578ed11d4d2d51e3de525e?narHash=sha256-jQnFEtH20/OsDPpx71ntZzGdRlpXhUENSQCGTjn//NA%3D' (2024-08-07) → 'github:nix-community/home-manager/c2cd2a52e02f1dfa1c88f95abeb89298d46023be?narHash=sha256-UNky3lJNGQtUEXT2OY8gMxejakSWPTfWKvpFkpFlAfM%3D' (2024-08-23) • Updated input 'nixpkgs': 'github:nixos/nixpkgs/cb9a96f23c491c081b38eab96d22fa958043c9fa?narHash=sha256-IAoYyYnED7P8zrBFMnmp7ydaJfwTnwcnqxUElC1I26Y%3D' (2024-08-04) → 'github:nixos/nixpkgs/71e91c409d1e654808b2621f28a327acfdad8dc2?narHash=sha256-GnR7/ibgIH1vhoy8cYdmXE6iyZqKqFxQSVkFgosBh6w%3D' (2024-08-28) • Updated input 'nur': 'github:nix-community/NUR/1b87f8f707527ec9e4347e3a5874396c0d572c8c?narHash=sha256-pOu0b2SjL9QW4aKEalPRSLwQzF5w2EjIH9uJd%2B9UhL0%3D' (2024-08-10) → 'github:nix-community/NUR/5a81fa6a427d4fa3b07655aa19eb4c188c849245?narHash=sha256-f7KRMBSX/JED2bzisE0g0p7k215AgXT8tI2KJAPoU30%3D' (2024-08-30) • Updated input 'stable': 'github:nixos/nixpkgs/21cc704b5e918c5fbf4f9fff22b4ac2681706d90?narHash=sha256-68hmex5efCiM2aZlAAEcQgmFI4ZwWt8a80vOeB/5w3A%3D' (2024-08-06) → 'github:nixos/nixpkgs/36bae45077667aff5720e5b3f1a5458f51cf0776?narHash=sha256-0XH9MJk54imJm%2BRHOLTUJ7e%2BponLW00tw5ke4MTVa1Y%3D' (2024-08-27)
72 lines
1.5 KiB
Nix
72 lines
1.5 KiB
Nix
{ ... }:
|
|
{
|
|
imports = [
|
|
./hardware.nix
|
|
];
|
|
|
|
config = {
|
|
mtxyz = {
|
|
platform = {
|
|
private = true;
|
|
portable = true;
|
|
minimal = false;
|
|
};
|
|
graphical.desktop = "kde";
|
|
};
|
|
|
|
hardware.bluetooth = {
|
|
enable = true; # enables support for Bluetooth
|
|
powerOnBoot = true; # powers up the default Bluetooth controller on boot
|
|
settings = {
|
|
General = {
|
|
Experimental = true;
|
|
};
|
|
};
|
|
};
|
|
|
|
services.tlp.settings = {
|
|
START_CHARGE_THRESH_BAT0 = 70;
|
|
STOP_CHARGE_THRESH_BAT0 = 80;
|
|
START_CHARGE_THRESH_BAT1 = 70;
|
|
STOP_CHARGE_THRESH_BAT1 = 80;
|
|
};
|
|
|
|
# enable graphics
|
|
hardware.graphics.enable = true;
|
|
|
|
services.xserver.videoDrivers = [ "nvidia" ];
|
|
environment.sessionVariables = {
|
|
GAMEMODERUNEXEC = "nvidia-offload";
|
|
};
|
|
|
|
hardware.nvidia = {
|
|
# Prime is needed for optimus GPU
|
|
prime = {
|
|
offload = {
|
|
enable = true;
|
|
enableOffloadCmd = true;
|
|
};
|
|
intelBusId = "PCI:0:2:0";
|
|
nvidiaBusId = "PCI:2:0:0";
|
|
};
|
|
|
|
open = false;
|
|
|
|
# Modesetting is needed for most Wayland compositors
|
|
modesetting.enable = true;
|
|
};
|
|
|
|
programs.gamemode = {
|
|
enable = true;
|
|
enableRenice = true;
|
|
settings = {
|
|
general.renice = 10;
|
|
gpu = {
|
|
apply_gpu_optimizations="accept-responsibility";
|
|
nv_powermizer_mode=2;
|
|
gpu_device=1;
|
|
};
|
|
};
|
|
};
|
|
};
|
|
}
|