nixconf/flake.nix

50 lines
1.1 KiB
Nix

{
description = "mtxyz's NixOS systems";
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
# Used in bodge overlay when an unstable package isn't working.
stable.url = "github:nixos/nixpkgs/nixos-24.05";
# Used in bodge overlay when a package is only up to date in master.
edge.url = "github:nixos/nixpkgs/master";
nur.url = "github:nix-community/NUR";
fenix = {
url = "github:nix-community/fenix/monthly";
inputs.nixpkgs.follows = "nixpkgs";
};
snowfall-lib = {
url = "github:snowfallorg/lib";
inputs.nixpkgs.follows = "nixpkgs";
};
home-manager = {
url = "github:nix-community/home-manager";
inputs.nixpkgs.follows = "nixpkgs";
};
};
outputs = inputs: inputs.snowfall-lib.mkFlake {
inherit inputs;
snowfall.namespace = "mtxyz";
channels-config.allowUnfree = true;
overlays = with inputs; [
nur.overlay
fenix.overlays.default
];
systems.modules.nixos = with inputs; [
home-manager.nixosModules.home-manager
];
templates.shim.description = "/etc/nixos shim for mtxyz's nixconf";
src = ./.;
};
}