guix/gnu/packages/patches/coreutils-fix-cross-compilation.patch
Manolis Ragkousis 82a7a8c667
gnu: coreutils: Fix cross-compilation.
* gnu/packages/patches/coreutils-fix-cross-compilation.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/base.scm (coreutils)[source]: Use it.
2017-01-27 10:19:25 +02:00

16 lines
604 B
Diff

Coreutils fails to cross compile for other platforms because cu_install_program
is not being evaluated properly. This patch fixes it.
See <https://lists.gnu.org/archive/html/coreutils/2017-01/msg00039.html>
--- a/Makefile.in
+++ b/Makefile.in
@@ -5023,7 +5023,7 @@ pr = progs-readme
@CROSS_COMPILING_FALSE@cu_install_program = src/ginstall
# Use the just-built 'ginstall', when not cross-compiling.
-@CROSS_COMPILING_TRUE@cu_install_program = @INSTALL_PROGRAM@
+@CROSS_COMPILING_TRUE@cu_install_program := @INSTALL@
info_TEXINFOS = doc/coreutils.texi
doc_coreutils_TEXINFOS = \
doc/perm.texi \