f267420707
* gnu/packages/emulation.scm (desmume): add patches * gnu/packages/patches/desmume-gcc6-fixes.patch: new file * gnu/packages/patches/desmume-gcc7-fixes.patch: new file * gnu/local.mk (dist_patch_DATA): register the above Note: desmume-gcc6-fixes.patch contains some CRLF line endings. Signed-off-by: Jakub Kądziołka <kuba@kadziolka.net>
18 lines
700 B
Diff
18 lines
700 B
Diff
From e1f7039f1b06add4fb75b2f8774000b8f05574af Mon Sep 17 00:00:00 2001
|
|
From: rogerman <rogerman@users.sf.net>
|
|
Date: Mon, 17 Aug 2015 21:15:04 +0000
|
|
Subject: Fix bug with libfat string handling.
|
|
|
|
diff --git a/src/utils/libfat/directory.cpp b/src/utils/libfat/directory.cpp
|
|
index 765d7ae5..b6d7f01f 100644
|
|
--- a/src/utils/libfat/directory.cpp
|
|
+++ b/src/utils/libfat/directory.cpp
|
|
@@ -139,7 +139,7 @@ static size_t _FAT_directory_mbstoucs2 (ucs2_t* dst, const char* src, size_t len
|
|
int bytes;
|
|
size_t count = 0;
|
|
|
|
- while (count < len-1 && src != '\0') {
|
|
+ while (count < len-1 && *src != '\0') {
|
|
bytes = mbrtowc (&tempChar, src, MB_CUR_MAX, &ps);
|
|
if (bytes > 0) {
|
|
*dst = (ucs2_t)tempChar;
|