guix/gnu/packages/patches/scotch-graph-induce-type-64.patch
Eric Bavier d98e9009a9
gnu: scotch: Update to 6.0.5a.
* gnu/packages/patches/pt-scotch-build-parallelism.patch: Delete files.
* gnu/packages/patches/scotch-build-parallelism.patch,
gnu/packages/patches/scotch-graph-diam-64.patch,
gnu/packages/patches/scotch-graph-induce-type-64.patch: New files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/maths.scm (scotch): Update to 6.0.5a.
[source](patches): Adjust accordingly.
2018-04-26 20:54:18 -05:00

20 lines
1.8 KiB
Diff

Fixes return type of SCOTCH_graphInduceList and SCOTCH_graphInducePart
so that the definition matches with -DINTSIZE64.
Reported upstream at
https://gforge.inria.fr/tracker/index.php?func=detail&aid=21608&group_id=248&atid=1081
--- scotch_6.0.5a/src/libscotch/library.h.orig 2018-02-11 10:52:38.000000000 -0600
+++ scotch_6.0.5a/src/libscotch/library.h 2018-02-23 16:56:41.000000000 -0600
@@ -199,8 +199,8 @@
int SCOTCH_graphGeomSaveChac (const SCOTCH_Graph * const, const SCOTCH_Geom * const, FILE * const, FILE * const, const char * const);
int SCOTCH_graphGeomSaveMmkt (const SCOTCH_Graph * const, const SCOTCH_Geom * const, FILE * const, FILE * const, const char * const);
int SCOTCH_graphGeomSaveScot (const SCOTCH_Graph * const, const SCOTCH_Geom * const, FILE * const, FILE * const, const char * const);
-int SCOTCH_graphInduceList (const SCOTCH_Graph * const, const SCOTCH_Num, const SCOTCH_Num * const, SCOTCH_Graph * const);
-int SCOTCH_graphInducePart (const SCOTCH_Graph * const, const SCOTCH_Num, const SCOTCH_GraphPart2 * const, const SCOTCH_GraphPart2, SCOTCH_Graph * const);
+SCOTCH_Num SCOTCH_graphInduceList (const SCOTCH_Graph * const, const SCOTCH_Num, const SCOTCH_Num * const, SCOTCH_Graph * const);
+SCOTCH_Num SCOTCH_graphInducePart (const SCOTCH_Graph * const, const SCOTCH_Num, const SCOTCH_GraphPart2 * const, const SCOTCH_GraphPart2, SCOTCH_Graph * const);
int SCOTCH_graphMapInit (const SCOTCH_Graph * const, SCOTCH_Mapping * const, const SCOTCH_Arch * const, SCOTCH_Num * const);
void SCOTCH_graphMapExit (const SCOTCH_Graph * const, SCOTCH_Mapping * const);