guix/gnu/packages/patches/python-disable-ssl-test.patch
Mark H Weaver 4c50e5ab3a gnu: python: Disable ssl test that fails with openssl-1.0.2b.
* gnu/packages/patches/python-disable-ssl-test.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/python.scm (python): Add patch.
2015-06-13 23:01:07 -04:00

13 lines
576 B
Diff

Disable a test that fails with openssl-1.0.2b.
--- Lib/test/test_ssl.py.orig 2015-02-25 06:27:45.000000000 -0500
+++ Lib/test/test_ssl.py 2015-06-12 03:14:09.395212502 -0400
@@ -2718,6 +2718,7 @@
chatty=True, connectionchatty=True)
self.assertIs(stats['compression'], None)
+ @unittest.skipIf(True, "openssl 1.0.2b complains: dh key too small")
def test_dh_params(self):
# Check we can get a connection with ephemeral Diffie-Hellman
context = ssl.SSLContext(ssl.PROTOCOL_TLSv1)