guix/gnu/packages/patches/julia-0.3.10-fix-empty-array.patch
Ricardo Wurmus 5ff0edaee6 gnu: julia: Update to 0.3.10.
* gnu/packages/julia.scm (julia): Update to 0.3.10.
* gnu/packages/patches/julia-0.3.10-fix-empty-array.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
2015-07-21 10:33:59 +02:00

14 lines
431 B
Diff

See https://github.com/JuliaLang/julia/issues/11817
--- a/src/codegen.cpp 2015-06-24 12:44:31.218674066 +0200
+++ b/src/codegen.cpp 2015-04-23 11:19:50.000000000 +0200
@@ -4551,7 +4551,7 @@
#ifdef V128_BUG
"-avx",
#endif
- };
+ ""};
SmallVector<std::string, 4> MAttrs(mattr, mattr+sizeof(mattr)/sizeof(mattr[0]));
EngineBuilder eb = EngineBuilder(engine_module)
.setEngineKind(EngineKind::JIT)