923bb70a1b
This is a follow-up to d08f5299e6
.
* gnu/packages/patches/glibc-bootstrap-system.patch: Update.
42 lines
1.5 KiB
Diff
42 lines
1.5 KiB
Diff
We want to allow builds in chroots that lack /bin/sh. Thus, system(3)
|
|
and popen(3) need to be tweaked to use the right shell. For the bootstrap
|
|
glibc, we just use whatever `sh' can be found in $PATH. The final glibc
|
|
instead uses the hard-coded absolute file name of `bash'.
|
|
|
|
In addition, status should be initialized to 0 and not -1.
|
|
|
|
diff --git a/libio/iopopen.c b/libio/iopopen.c
|
|
index ebc381ed7c..e0d3ed1bc3 100644
|
|
--- a/libio/iopopen.c
|
|
+++ b/libio/iopopen.c
|
|
@@ -85,7 +85,7 @@ spawn_process (posix_spawn_file_actions_t *fa, FILE *fp, const char *command,
|
|
return false;
|
|
}
|
|
|
|
- if (__posix_spawn (&((_IO_proc_file *) fp)->pid, _PATH_BSHELL, fa, 0,
|
|
+ if (posix_spawnp (&((_IO_proc_file *) fp)->pid, "sh", fa, 0,
|
|
(char *const[]){ (char*) "sh", (char*) "-c",
|
|
(char *) command, NULL }, __environ) != 0)
|
|
return false;
|
|
diff --git a/sysdeps/posix/system.c b/sysdeps/posix/system.c
|
|
index a03f478fc7..94da6facf3 100644
|
|
--- a/sysdeps/posix/system.c
|
|
+++ b/sysdeps/posix/system.c
|
|
@@ -101,7 +101,7 @@ cancel_handler (void *arg)
|
|
static int
|
|
do_system (const char *line)
|
|
{
|
|
- int status = -1;
|
|
+ int status = 0;
|
|
int ret;
|
|
pid_t pid;
|
|
struct sigaction sa;
|
|
@@ -145,7 +145,7 @@ do_system (const char *line)
|
|
__posix_spawnattr_setflags (&spawn_attr,
|
|
POSIX_SPAWN_SETSIGDEF | POSIX_SPAWN_SETSIGMASK);
|
|
|
|
- ret = __posix_spawn (&pid, SHELL_PATH, 0, &spawn_attr,
|
|
+ ret = posix_spawnp (&pid, SHELL_NAME, 0, &spawn_attr,
|
|
(char *const[]){ (char *) SHELL_NAME,
|
|
(char *) "-c",
|
|
(char *) line, NULL },
|