36a09d1853
* gnu/packages/emacs.scm (emacs): Update to 27.1. [source]: In snippet, use 'find-files' to find 'eshell/esh-groups.el' if it exists, but gracefully handle its absence. [arguments]: Add "--with-cairo" to configure-flags. Add 'restore-emacs-pdmp' and 'make-compressed-files-writable' phases. Explicitly return #t from 'install-site-start' phase. [inputs]: Add cairo, pango, harfbuzz, jansson, and gmp. Remove imagemagick. (emacs-next): Remove variable. (emacs-minimal, emacs-xwidgets): Use 'package/inherit'. [arguments]: Remove 'restore-emacs-pdmp' phase. (emacs-no-x): Use 'package/inherit'. [arguments]: Remove "--with-cairo" from configure-flags. Remove 'restore-emacs-pdmp' phase. [inputs]: Remove cairo, pango, and harfbuzz. (emacs-no-x-toolkit): Use 'package/inherit'. [arguments]: Remove 'restore-emacs-pdmp' phase. Remove superfluous quasiquote+unquote-splicing pair. (emacs-wide-int): Use 'package/inherit'. (guile-emacs): Use 'package/inherit'. [arguments]: Remove "--with-cairo" from configure-flags. Remove 'restore-emacs-pdmp' phase. * gnu/packages/patches/emacs-ignore-empty-xim-styles.patch, gnu/packages/patches/emacs-source-date-epoch.patch: Adapt to apply cleanly to emacs-27.1. * gnu/packages/patches/emacs-exec-path.patch: Replace with the previous contents of 'emacs27-exec-path.patch', but remove the superfluous comment about it being "like emacs-exec-path.patch, but for Emacs 27". * gnu/packages/patches/emacs27-exec-path.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove 'emacs27-exec-path.patch'.
16 lines
763 B
Diff
16 lines
763 B
Diff
Do not capture the build-time value of $PATH in the 'emacs' executable
|
|
since this can noticeably increase the size of the closure of Emacs
|
|
with things like GCC being referenced.
|
|
|
|
--- a/lisp/loadup.el
|
|
+++ b/lisp/loadup.el
|
|
@@ -481,7 +481,8 @@ lost after dumping")))
|
|
((equal dump-mode "dump") "emacs")
|
|
((equal dump-mode "bootstrap") "emacs")
|
|
((equal dump-mode "pbootstrap") "bootstrap-emacs.pdmp")
|
|
- (t (error "unrecognized dump mode %s" dump-mode)))))
|
|
+ (t (error "unrecognized dump mode %s" dump-mode))))
|
|
+ (exec-path nil))
|
|
(message "Dumping under the name %s" output)
|
|
(condition-case ()
|
|
(delete-file output)
|