24e20d419b
Includes fixes for CVE-2023-0767, CVE-2023-25728, CVE-2023-25729, CVE-2023-25730, CVE-2023-25732, CVE-2023-25734, CVE-2023-25735, CVE-2023-25737, CVE-2023-25738, CVE-2023-25739, CVE-2023-25742, CVE-2023-25743, CVE-2023-25744, and CVE-2023-25746. * gnu/packages/gnuzilla.scm (%icecat-version, %icecat-build-id): Update. (icecat-source): Update gnuzilla commit, base version, and hashes. Remove the dependency on the Perl 'rename' program. * gnu/packages/patches/icecat-makeicecat.patch: Update to apply cleanly.
51 lines
1.4 KiB
Diff
51 lines
1.4 KiB
Diff
Make some of the changes needed to the 'makeicecat' script, to allow it to run
|
|
in a snippet without network access. After this patch is applied, some
|
|
additional changes will be made using 'substitute*'.
|
|
|
|
diff --git a/makeicecat b/makeicecat
|
|
index bf2b7a6..bc3b19b 100755
|
|
--- a/makeicecat
|
|
+++ b/makeicecat
|
|
@@ -56,7 +56,7 @@ readonly SOURCEDIR=icecat-${FFVERSION}
|
|
# debug/shell options
|
|
readonly DEVEL=0
|
|
set -euo pipefail
|
|
-(( DEVEL )) && set -x
|
|
+set -x
|
|
|
|
|
|
###############################################################################
|
|
@@ -455,7 +455,7 @@ configure_search()
|
|
|
|
|
|
# Process various JSON pre-configuration dumps.
|
|
- python3 ../../tools/process-json-files.py . browser/components/extensions/schemas/
|
|
+ python3 "${DATADIR}"/../tools/process-json-files.py . browser/components/extensions/schemas/
|
|
}
|
|
|
|
configure_mobile()
|
|
@@ -837,12 +837,12 @@ finalize_sourceball()
|
|
# entry point
|
|
###############################################################################
|
|
|
|
-validate_env || exit 1
|
|
-prepare_env
|
|
-fetch_source
|
|
-verify_sources
|
|
-extract_sources
|
|
-fetch_l10n
|
|
+# validate_env || exit 1
|
|
+# prepare_env
|
|
+# fetch_source
|
|
+# verify_sources
|
|
+# extract_sources
|
|
+# fetch_l10n
|
|
apply_patches
|
|
configure
|
|
configure_search
|
|
@@ -854,4 +854,4 @@ prepare_macos_packaging
|
|
configure_extensions
|
|
configure_onboarding
|
|
apply_bugfixes
|
|
-finalize_sourceball
|
|
+# finalize_sourceball
|