guix/gnu/packages/patches/widelands-add-missing-map-include.patch
Felix Gruber a83dc5022b
gnu: widelands: Fix build against boost 1.77.
Widelands fails to build with boost 1.77 due to a missing include in one
of Wideland's header files that was previously indirectly included by
boost 1.76.

* gnu/packages/patches/widelands-add-missing-map-include.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/games.scm (widelands)[source]: Add patch.

Signed-off-by: Leo Famulari <leo@famulari.name>
2022-01-01 23:22:59 -05:00

29 lines
788 B
Diff

From 316eaea209754368a57f445ea4dd016ecf8eded6 Mon Sep 17 00:00:00 2001
From: matthiakl <t-m.42@mailpost.spdns.org>
Date: Sat, 14 Aug 2021 19:24:08 +0200
Subject: [PATCH] Added missing direct incude (#5025)
---
This patch is from
https://github.com/widelands/widelands/pull/5025
which has been merged after the release of Widelands 1.0.
src/network/bufferedconnection.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/network/bufferedconnection.h b/src/network/bufferedconnection.h
index fe974b9e..7e1ecf87 100644
--- a/src/network/bufferedconnection.h
+++ b/src/network/bufferedconnection.h
@@ -20,6 +20,7 @@
#ifndef WL_NETWORK_BUFFEREDCONNECTION_H
#define WL_NETWORK_BUFFEREDCONNECTION_H
+#include <map>
#include <memory>
#include <mutex>
#include <thread>
--
2.30.2