guix/gnu/packages/patches/upower-builddir.patch
Tobias Geerinckx-Rice 35188a8257
gnu: upower: Build from Git sources.
* gnu/packages/gnome.scm (upower)[source]: Use GIT-FETCH and
GIT-FILE-NAME.  Adjust snippet.
[native-inputs]: Add autoconf, automake, gtk-doc, libtool, and which.
* gnu/packages/patches/upower-builddir.patch: Adjust to Makefile.am.
2021-06-28 18:04:15 +02:00

35 lines
1.1 KiB
Diff

From 27ae011b31d831752b97eb209bc2b2206fcf40f7 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Mon, 28 Jun 2021 11:58:47 +0200
Subject: [PATCH] gnu: upower: Fix build directory.
Remove explicit set of UPOWER_CONF_FILE_NAME in up-self-test.c;
instead the harness should set it. In Guix we set it explicitly; the
right thing is to use AM_TEST_ENVIRONMENT and regenerate the
makefiles, but we can't regenerate because current autotools carp on
some things, so we patch the Makefile.in instead.
Also fix to not try to create /var/lib/upower if /var isn't writable.
Based on a patch by Andy Wingo <wingo@igalia.com>
---
src/Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/Makefile.am b/src/Makefile.am
index 3400139..f51ee89 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -181,7 +181,7 @@ $(systemdservice_DATA): $(systemdservice_in_files) Makefile
endif
install-data-hook:
- if test -w $(DESTDIR)$(prefix)/; then \
+ if test -w $(DESTDIR)$(localstatedir)/; then \
mkdir -p $(DESTDIR)$(historydir); \
fi
--
2.32.0