guix/gnu/packages/patches/qpdfview-qt515-compat.patch
Timotej Lazar 1e9f667708
gnu: qpdfview: Fix qt-5.15 compatibility.
* gnu/packages/pdf.scm (qpdfview)[source]: Add patch to include a missing
header.
* gnu/packages/patches/qpdfview-qt515-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Leo Famulari <leo@famulari.name>
2021-02-09 14:53:01 -05:00

18 lines
399 B
Diff

Fix compatibility with Qt 5.15.
Patch copied from upstream source repository:
https://bazaar.launchpad.net/~adamreichold/qpdfview/trunk/revision/2104
--- a/sources/model.h 2017-04-19 21:01:25 +0000
+++ b/sources/model.h 2020-06-09 06:24:11 +0000
@@ -24,6 +24,7 @@
#define DOCUMENTMODEL_H
#include <QList>
+#include <QPainterPath>
#include <QtPlugin>
#include <QWidget>
#include <QVector>