guix/gnu/packages/patches/ganeti-haskell-compat.patch
Marius Bakke 0105f33a4d
gnu: ganeti: Adjust to GHC 8.10 / Stackage 18.10.
* gnu/packages/patches/ganeti-haskell-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/virtualization.scm (ganeti)[source](patches): Add it.
[arguments]: Add phase patch-version-constraints.
2021-10-11 21:53:31 +02:00

19 lines
614 B
Diff

Adjust to type change of TupE in Template Haskell 2.16.
diff --git a/src/Ganeti/THH/Types.hs b/src/Ganeti/THH/Types.hs
--- a/src/Ganeti/THH/Types.hs
+++ b/src/Ganeti/THH/Types.hs
@@ -123,4 +123,11 @@ curryN n = do
f <- newName "f"
ps <- replicateM n (newName "x")
return $ LamE (VarP f : map VarP ps)
- (AppE (VarE f) (TupE $ map VarE ps))
+ (AppE (VarE f) (nonUnaryTupE $ map VarE ps))
+ where
+ nonUnaryTupE :: [Exp] -> Exp
+ nonUnaryTupE es = TupE $
+#if MIN_VERSION_template_haskell(2,16,0)
+ map Just
+#endif
+ es