guix/gnu/packages/patches/ceph-boost-compat.patch
Marius Bakke 1525443e02
gnu: ceph: Update to 16.2.6.
* gnu/packages/storage.scm (ceph): Update to 16.2.6.
[source](patches): Add two new patches.  Remove one obsolete.
[source](snippet): Unbundle fmt.
[arguments]: Remove -DWITH_PYTHON3 from #:configure-flags. Add
-DWITH_SYSTEMD.  Adjust RUNPATH substitution, and the wrap-python-scripts
phase, for upstream changes.  Remove trailing #t's.
[inputs]: Remove PYTHON-SIX and PYTHON-WRAPPER.  Add FMT, ICU4C,
PYTHON-PYYAML, PYTHON, and SQLITE.
* gnu/packages/patches/ceph-fix-snappy-breaking-change.patch: Delete file.
* gnu/packages/patches/ceph-boost-compat.patch,
gnu/packages/patches/ceph-rocksdb-compat.patch: New files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
2021-11-06 17:41:41 +01:00

19 lines
479 B
Diff

Add extra includes required for Boost 1.75 and later.
Taken from upstram:
https://github.com/ceph/ceph/commit/ebf3a0398f18eab67d2ba25e6a10b41ff140f6a4
diff --git a/src/rgw/rgw_string.h b/src/rgw/rgw_string.h
index 257daa9c1fe6e..90e64f98a2587 100644
--- a/src/rgw/rgw_string.h
+++ b/src/rgw/rgw_string.h
@@ -8,5 +8,7 @@
#include <stdlib.h>
#include <limits.h>
#include <string_view>
+#include <string>
+#include <stdexcept>
#include <boost/container/small_vector.hpp>