0d4587d65f
* gnu/packages/patches/u-boot-infodocs-target.patch: New patch. * gnu/local.mk: (dist_patch_DATA): Register it. * gnu/packages/bootloaders.scm (u-boot): Apply it. (u-boot-documentation): New variable.
84 lines
2.8 KiB
Diff
84 lines
2.8 KiB
Diff
Upstream status: https://patchwork.ozlabs.org/project/uboot/list/?series=333259
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index de5746399a..597a8886c3 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -2372,7 +2372,7 @@ tcheck:
|
|
# Documentation targets
|
|
# ---------------------------------------------------------------------------
|
|
DOC_TARGETS := xmldocs latexdocs pdfdocs htmldocs epubdocs cleandocs \
|
|
- linkcheckdocs dochelp refcheckdocs
|
|
+ linkcheckdocs dochelp refcheckdocs texinfodocs infodocs
|
|
PHONY += $(DOC_TARGETS)
|
|
$(DOC_TARGETS): scripts_basic FORCE
|
|
$(Q)$(MAKE) $(build)=doc $@
|
|
diff --git a/doc/Makefile b/doc/Makefile
|
|
index f5de65e927..d0904a9f99 100644
|
|
--- a/doc/Makefile
|
|
+++ b/doc/Makefile
|
|
@@ -69,6 +69,14 @@ quiet_cmd_sphinx = SPHINX $@ --> file://$(abspath $(BUILDDIR)/$3/$4)
|
|
htmldocs:
|
|
@+$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,html,$(var),,$(var)))
|
|
|
|
+texinfodocs:
|
|
+ @+$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,texinfo,$(var),texinfo,$(var)))
|
|
+
|
|
+# Note: the 'info' Make target is generated by sphinx itself when
|
|
+# running the texinfodocs target defined above.
|
|
+infodocs: texinfodocs
|
|
+ $(MAKE) -C $(BUILDDIR)/texinfo info
|
|
+
|
|
linkcheckdocs:
|
|
@$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,linkcheck,$(var),,$(var)))
|
|
|
|
@@ -109,6 +117,8 @@ cleandocs:
|
|
dochelp:
|
|
@echo ' U-Boot documentation in different formats from ReST:'
|
|
@echo ' htmldocs - HTML'
|
|
+ @echo ' texinfodocs - Texinfo'
|
|
+ @echo ' infodocs - Info'
|
|
@echo ' latexdocs - LaTeX'
|
|
@echo ' pdfdocs - PDF'
|
|
@echo ' epubdocs - EPUB'
|
|
diff --git a/doc/conf.py b/doc/conf.py
|
|
index 62c8d31270..3db70f80c1 100644
|
|
--- a/doc/conf.py
|
|
+++ b/doc/conf.py
|
|
@@ -449,7 +449,7 @@ for fn in os.listdir('.'):
|
|
# One entry per manual page. List of tuples
|
|
# (source start file, name, description, authors, manual section).
|
|
man_pages = [
|
|
- (master_doc, 'dasuboot', 'The U-Boot Documentation',
|
|
+ (master_doc, 'u-boot', 'The U-Boot Documentation',
|
|
[author], 1)
|
|
]
|
|
|
|
@@ -463,8 +463,8 @@ man_pages = [
|
|
# (source start file, target name, title, author,
|
|
# dir menu entry, description, category)
|
|
texinfo_documents = [
|
|
- (master_doc, 'DasUBoot', 'The U-Boot Documentation',
|
|
- author, 'DasUBoot', 'One line description of project.',
|
|
+ (master_doc, 'u-boot', 'The U-Boot Documentation',
|
|
+ author, 'U-Boot', 'Boot loader for embedded systems',
|
|
'Miscellaneous'),
|
|
]
|
|
|
|
diff --git a/doc/media/Makefile b/doc/media/Makefile
|
|
index b9b43a34c3..9b32258696 100644
|
|
--- a/doc/media/Makefile
|
|
+++ b/doc/media/Makefile
|
|
@@ -22,10 +22,11 @@ $(BUILDDIR)/linker_lists.h.rst: ${API}/linker_lists.h ${PARSER} $(SRC_DIR)/linke
|
|
|
|
# Media build rules
|
|
|
|
-.PHONY: all html epub xml latex
|
|
+.PHONY: all html texinfo epub xml latex
|
|
|
|
all: $(IMGDOT) $(BUILDDIR) ${TARGETS}
|
|
html: all
|
|
+texinfo: all
|
|
epub: all
|
|
xml: all
|
|
latex: $(IMGPDF) all
|