298b349a05
* gnu/packages/kde-pim.scm (KDE PIM): Update to 21.12.3. (akonadi, akonadi-calendar, akonadi-contacts, akonadi-mime, akonadi-notes, akonadi-search, kaddressbook, kalarmcal, kcalendarsupport, kcalutils, kdepim-runtime, keventviews, kgpg, kidentitymanagement, kimap, kincidenceeditor, kldap, kleopatra, kmail, kmailcommon, kmailimporter, kmailtransport, kmbox, kmessagelib, kmime, knotes, kontactinterface, korganizer, kpeoplevcard, kpimcommon, kpimtextedit, ksmtp, ktnef, libgravatar, libkdepim, libkgapi, libkleo, libksieve): Update to 21.12.3. (kblog): Update to 20.04.3. * gnu/packages/patches/akonadi-not-relocatable.patch * gnu/packages/patches/akonadi-paths.patch * gnu/packages/patches/akonadi-timestamps.patch Fix patches to apply to latest code. (akonadi-calendar): [inputs]: Add new dependencies. (akonadi-contacts): [inputs]: Add new dependencies. (akonadi-search): [arguments]: Disable failing tests. (kcalendarsupport): [inputs]: Add new dependency, remove obsolete kdepim-apps-lib. (libksieve): [arguments]: Enable test that works now. * gnu/packages/patches/libksieve-Fix-missing-link-libraries.patch: Fix patch. (kaddressbook): [inputs]: Remove obsolete kdepim-apps-libs. Move kdocstools to native-inputs. (kmessagelib): [inputs]: Remove obsolete kdepim-appslibs, add kguiaddons. [arguments]: Fix findind header file. (kmailimporter): [inputs]: Add new dependencies. (kmailtransport): [inputs]: Add qtkeychain. (knotes): [inputs]: Move kdocstools to native-inputs. (kincidenceeditor): [inputs]: Add new dependencies. Remove obsolete kdepim-apps-libs [arguments]: Disable failing test. (kldap): [inputs]: Add qtkeychain. (kgpg)[arguments]: Disable failing tests. (libkleo): [propagated-inputs]: Propagate gpgme, qgpgme. [arguments]: Disable failing tests. (kdepim-runtime): [inputs]: Add new dependencies grantlee, grantleetheme, kcmutils, kldap, libkdepim, qtkeychain [arguments]: Enable all the tests that pass. We need to use the old hack instead of search-input-directory to workaround a mysterious include error. (kdepim-apps-lib): Remove obsolete package. (kmail): [origin]: Remove patch. Don't think it is needed anymore. [inputs]: Add new dependencies, delete obsolete kdepim-apps-libs and duplicate kmime. [arguments]: Disable failing tests. * gnu/packages/patches/kmail-Fix-missing-link-libraries.patch: Delete file. * gnu/local.mk: Remove reference to patch. (kmailcommon): [inputs]: Add new dependencies. Signed-off-by: Marius Bakke <marius@gnu.org>
14 lines
815 B
Diff
14 lines
815 B
Diff
Index: akonadi-19.08.0/src/server/storage/dbconfigmysql.cpp
|
|
===================================================================
|
|
--- akonadi-19.08.0.orig/src/server/storage/dbconfigmysql.cpp
|
|
+++ akonadi-19.08.0/src/server/storage/dbconfigmysql.cpp
|
|
@@ -260,8 +260,7 @@ bool DbConfigMysql::startInternalServer(
|
|
bool confUpdate = false;
|
|
QFile actualFile(actualConfig);
|
|
// update conf only if either global (or local) is newer than actual
|
|
- if ((QFileInfo(globalConfig).lastModified() > QFileInfo(actualFile).lastModified())
|
|
- || (QFileInfo(localConfig).lastModified() > QFileInfo(actualFile).lastModified())) {
|
|
+ if (true) {
|
|
QFile globalFile(globalConfig);
|
|
QFile localFile(localConfig);
|
|
if (globalFile.open(QFile::ReadOnly) && actualFile.open(QFile::WriteOnly)) {
|