guix/gnu/packages/patches/python-sqlite-3.8.4-test-fix.patch
Eric Bavier b88e1b0a62 gnu: python: Add sqlite input.
* gnu/packages/patches/python-sqlite-3.8.4-test-fix.patch,
  gnu/packages/patches/python2-sqlite-3.8.4-test-fix.patch: New patches.
* gnu-system.am (dist_patch_DATA): Add them.
* gnu/packages/python.scm (python-2)[source]: Add patch.
  [inputs]: Add sqlite.
  (python)[source]: Add patch.
2014-12-02 08:33:31 -06:00

16 lines
538 B
Diff

From resolution of upstream python issue #20901: http://bugs.python.org/issue20901
diff --git a/Lib/sqlite3/test/hooks.py b/Lib/sqlite3/test/hooks.py
--- Lib/sqlite3/test/hooks.py
+++ Lib/sqlite3/test/hooks.py
@@ -162,7 +162,7 @@ class ProgressTests(unittest.TestCase):
create table bar (a, b)
""")
second_count = len(progress_calls)
- self.assertGreater(first_count, second_count)
+ self.assertGreaterEqual(first_count, second_count)
def CheckCancelOperation(self):
"""