guix/gnu/packages/patches/hdf-eos5-fix-szip.patch
Thomas Danckaert 0f43f8354c
gnu: Add hdf-eos5.
* gnu/packages/maths.scm (hdf-eos5): New variable.
* gnu/packages/patches/hdf-eos5-build-shared.patch: New file.
* gnu/packages/patches/hdf-eos5-remove-gctp.patch: New file.
* gnu/packages/patches/hdf-eos5-fix-szip.patch: New file.
* gnu/packages/patches/hdf-eos5-fortrantests.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add patches.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2016-10-06 18:14:45 +02:00

31 lines
622 B
Diff

Ill-placed #endif causes missing symbol errors when compiling without
szip. Reported to upstream maintainer.
---
src/EHapi.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/src/EHapi.c b/src/EHapi.c
index 46a9b5c..208f447 100755
--- a/src/EHapi.c
+++ b/src/EHapi.c
@@ -11379,6 +11379,7 @@ int HE5_szip_can_encode(void )
return(-1);
}
+#endif /* H5_HAVE_FILTER_SZIP */
/*----------------------------------------------------------------------------|
@@ -11509,8 +11510,6 @@ HE5_EHHEisHE5(char *filename)
}
}
-#endif /* H5_HAVE_FILTER_SZIP */
-
#ifndef __cplusplus
--
2.10.0