a33eac038a
* gnu/packages/patches/glibc-supported-locales.patch: Adjust for upstream changes. * gnu/packages/patches/glibc-2.29-supported-locales.patch: New file, with previous contents. * gnu/packages/patches/gcc-4.9-libsanitizer-mode-size.patch, gnu/packages/patches/gcc-6-libsanitizer-mode-size.patch, gnu/packages/patches/gcc-7-libsanitizer-mode-size.patch, gnu/packages/patches/gcc-8-libsanitizer-mode-size.patch, gnu/packages/patches/gcc-9-libsanitizer-mode-size.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/gcc.scm (gcc-4.9, gcc-5, gcc-6, gcc-7, gcc-8, gcc-9)[source](patches): Add the respective patch files. * gnu/packages/base.scm (glibc): Update to 2.31. [source](patches): Remove obsolete. (glibc-2.30): New public variable. (glibc-2.29)[source](patches): Adjust for renamed patch file.
53 lines
2 KiB
Diff
53 lines
2 KiB
Diff
Fix assertion failure in libsanitizer when using glibc 2.31 and later.
|
|
|
|
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=92154
|
|
https://reviews.llvm.org/D69104
|
|
|
|
Adapted from these upstream revision:
|
|
|
|
https://gcc.gnu.org/viewcvs/gcc?view=revision&revision=277981
|
|
https://gcc.gnu.org/viewcvs/gcc?view=revision&revision=279653
|
|
|
|
diff --git a/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc b/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc
|
|
index 069d8d557de..c49c28c6e07 100644
|
|
--- a/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc
|
|
+++ b/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc
|
|
@@ -1130,8 +1130,9 @@ CHECK_SIZE_AND_OFFSET(ipc_perm, cgid);
|
|
#ifndef __GLIBC_PREREQ
|
|
#define __GLIBC_PREREQ(x, y) 0
|
|
#endif
|
|
-#if !defined(__aarch64__) || !SANITIZER_LINUX || __GLIBC_PREREQ (2, 21)
|
|
-/* On aarch64 glibc 2.20 and earlier provided incorrect mode field. */
|
|
+#if !SANITIZER_LINUX || __GLIBC_PREREQ (2, 31)
|
|
+/* glibc 2.30 and earlier provided 16-bit mode field instead of 32-bit
|
|
+ on many architectures. */
|
|
CHECK_SIZE_AND_OFFSET(ipc_perm, mode);
|
|
#endif
|
|
|
|
diff --git a/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.h b/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.h
|
|
index 304d04e3935..6dee89c97e1 100644
|
|
--- a/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.h
|
|
+++ b/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.h
|
|
@@ -207,20 +207,13 @@ namespace __sanitizer {
|
|
unsigned long __unused1;
|
|
unsigned long __unused2;
|
|
#elif defined(__sparc__)
|
|
-# if defined(__arch64__)
|
|
unsigned mode;
|
|
- unsigned short __pad1;
|
|
-# else
|
|
- unsigned short __pad1;
|
|
- unsigned short mode;
|
|
unsigned short __pad2;
|
|
-# endif
|
|
unsigned short __seq;
|
|
unsigned long long __unused1;
|
|
unsigned long long __unused2;
|
|
#else
|
|
- unsigned short mode;
|
|
- unsigned short __pad1;
|
|
+ unsigned int mode;
|
|
unsigned short __seq;
|
|
unsigned short __pad2;
|
|
#if defined(__x86_64__) && !defined(_LP64)
|
|
|