e58652502b
* gnu/packages/patches/gawk-shell.patch: Update for gawk 4.1.3.
34 lines
1.2 KiB
Diff
34 lines
1.2 KiB
Diff
As for libc's `system', change Awk to look for `sh' in $PATH. This patch is
|
|
only meant to be used during bootstrapping, where we don't know in advance the
|
|
absolute file name of `sh'.
|
|
|
|
--- gawk-4.1.3/io.c 2015-05-19 15:37:20.000000000 +0200
|
|
+++ gawk-4.1.3/io.c 2015-06-09 18:39:36.918414881 +0200
|
|
@@ -1945,7 +1945,7 @@ two_way_open(const char *str, struct red
|
|
|
|
signal(SIGPIPE, SIG_DFL);
|
|
|
|
- execl("/bin/sh", "sh", "-c", str, NULL);
|
|
+ execlp("sh", "sh", "-c", str, NULL);
|
|
_exit(errno == ENOENT ? 127 : 126);
|
|
|
|
case -1:
|
|
@@ -2129,7 +2129,7 @@ use_pipes:
|
|
fatal(_("close of pipe failed (%s)"), strerror(errno));
|
|
/* stderr does NOT get dup'ed onto child's stdout */
|
|
signal(SIGPIPE, SIG_DFL);
|
|
- execl("/bin/sh", "sh", "-c", str, NULL);
|
|
+ execlp("sh", "sh", "-c", str, NULL);
|
|
_exit(errno == ENOENT ? 127 : 126);
|
|
}
|
|
#endif /* NOT __EMX__, NOT __MINGW32__ */
|
|
@@ -2323,7 +2323,7 @@ gawk_popen(const char *cmd, struct redir
|
|
if (close(p[0]) == -1 || close(p[1]) == -1)
|
|
fatal(_("close of pipe failed (%s)"), strerror(errno));
|
|
signal(SIGPIPE, SIG_DFL);
|
|
- execl("/bin/sh", "sh", "-c", cmd, NULL);
|
|
+ execlp("sh", "sh", "-c", cmd, NULL);
|
|
_exit(errno == ENOENT ? 127 : 126);
|
|
}
|
|
#endif /* NOT __EMX__, NOT __MINGW32__ */
|
|
|