guix/gnu/packages/patches/curl-bounds-check.patch
Marius Bakke d5daf6fbe0
gnu: curl: Fix i686 test failure.
* gnu/packages/patches/curl-bounds-check.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/curl.scm (curl-7.55.0)[source]: Use it.
2017-08-13 16:46:41 +02:00

20 lines
617 B
Diff

Fix test failure on some 32-bit platforms.
Patch copied from upstream source repository:
https://github.com/curl/curl/commit/45a560390c4356bcb81d933bbbb229c8ea2acb63
diff --git a/src/tool_paramhlp.c b/src/tool_paramhlp.c
index b9dedc989e..85c5e79a7e 100644
--- a/src/tool_paramhlp.c
+++ b/src/tool_paramhlp.c
@@ -218,7 +218,7 @@ static ParameterError str2double(double *val, const char *str, long max)
num = strtod(str, &endptr);
if(errno == ERANGE)
return PARAM_NUMBER_TOO_LARGE;
- if((long)num > max) {
+ if(num > max) {
/* too large */
return PARAM_NUMBER_TOO_LARGE;
}