c902458863
This adds the elm compiler, version 0.19.0. This provides the `elm` command, with the exception of the `elm reactor` subcommand. Named `elm-compiler`, to leave space for `elm` as the full elm including reactor. * gnu/packages/elm.scm: New module. (elm-compiler): New package. * gnu/packages/patches/elm-disable-reactor.patch: New patch. * gnu/packages/patches/elm-fix-map-key.patch: New patch. * gnu/packages/patches/elm-relax-glsl-bound.patch: New patch. * gnu/local.mk: Add new files. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
19 lines
589 B
Diff
19 lines
589 B
Diff
commit 4c649a5a270aba15cc6a3913c3ad51a293047f40
|
|
Author: Rémi Lefèvre <rlefevre@gmail.com>
|
|
Date: Mon Sep 3 19:18:54 2018 +0200
|
|
|
|
update language-glsl maximum version
|
|
|
|
diff --git a/elm.cabal b/elm.cabal
|
|
index 48aa84f0..464fe9d5 100644
|
|
--- a/elm.cabal
|
|
+++ b/elm.cabal
|
|
@@ -246,7 +246,7 @@ Executable elm
|
|
http-client >= 0.5 && < 0.6,
|
|
http-client-tls >= 0.3 && < 0.4,
|
|
http-types >= 0.9 && < 1.0,
|
|
- language-glsl >= 0.0.2 && < 0.3,
|
|
+ language-glsl >= 0.0.2 && < 0.4,
|
|
logict,
|
|
mtl >= 2.2.1 && < 3,
|
|
network >= 2.4 && < 2.7,
|