800cdeef31
* Makefile.am (nobase_dist_guilemodule_DATA): Keep only $(MODULES). (patchdir): New variable. (dist_patch_DATA): New variable. Patch files formerly in $(nobase_dist_guilemodule_DATA). (.scm.go): Define `DISTRO_PATCH_DIRECTORY' and `DISTRO_INSTALLED_PATCH_DIRECTORY'. (TESTS_ENVIRONMENT): Define `DISTRO_PATCH_DIRECTORY'. * distro.scm (%patch-directory): New variable. (search-patch): New procedure. * distro/base.scm: Use `search-patch' instead of `(search-path %load-path ...)'. * distro/findutils-absolute-paths.patch, distro/guile-1.8-cpp-4.5.patch, distro/m4-readlink-EINVAL.patch, distro/m4-s_isdir.patch, distro/make-impure-dirs.patch: Move to `distro/patches'.
18 lines
695 B
Diff
18 lines
695 B
Diff
This patch is to make sure that `libncurses' is among the `NEEDED'
|
|
dependencies of `libreadline.so' and `libhistory.so'.
|
|
|
|
Failing to do that, applications linking against Readline are
|
|
forced to explicitly link against libncurses as well; in addition,
|
|
this trick doesn't work when using GNU ld's `--as-needed'.
|
|
|
|
--- shlib/Makefile.in 2009-01-06 18:03:22.000000000 +0100
|
|
+++ shlib/Makefile.in 2009-07-27 14:43:25.000000000 +0200
|
|
@@ -84,7 +84,7 @@ SHOBJ_LDFLAGS = @SHOBJ_LDFLAGS@
|
|
SHOBJ_XLDFLAGS = @SHOBJ_XLDFLAGS@
|
|
SHOBJ_LIBS = @SHOBJ_LIBS@
|
|
|
|
-SHLIB_XLDFLAGS = @LDFLAGS@ @SHLIB_XLDFLAGS@
|
|
+SHLIB_XLDFLAGS = @LDFLAGS@ @SHLIB_XLDFLAGS@ -lncurses
|
|
SHLIB_LIBS = @SHLIB_LIBS@
|
|
|
|
SHLIB_DOT = @SHLIB_DOT@
|