800cdeef31
* Makefile.am (nobase_dist_guilemodule_DATA): Keep only $(MODULES). (patchdir): New variable. (dist_patch_DATA): New variable. Patch files formerly in $(nobase_dist_guilemodule_DATA). (.scm.go): Define `DISTRO_PATCH_DIRECTORY' and `DISTRO_INSTALLED_PATCH_DIRECTORY'. (TESTS_ENVIRONMENT): Define `DISTRO_PATCH_DIRECTORY'. * distro.scm (%patch-directory): New variable. (search-patch): New procedure. * distro/base.scm: Use `search-patch' instead of `(search-path %load-path ...)'. * distro/findutils-absolute-paths.patch, distro/guile-1.8-cpp-4.5.patch, distro/m4-readlink-EINVAL.patch, distro/m4-s_isdir.patch, distro/make-impure-dirs.patch: Move to `distro/patches'.
29 lines
1.2 KiB
Diff
29 lines
1.2 KiB
Diff
Fix use of LFS-style absolute paths.
|
|
|
|
Patches from Nixpkgs by Armijn Hemel <armijn@gpl-violations.org>
|
|
and Wouter den Breejen <uu@denbreejen.net>.
|
|
|
|
diff -ruN findutils-4.2.20/locate/updatedb.sh findutils-4.2.20.new/locate/updatedb.sh
|
|
--- findutils-4.2.20/locate/updatedb.sh 2005-01-24 17:12:35.000000000 +0100
|
|
+++ findutils-4.2.20.new/locate/updatedb.sh 2005-08-23 14:37:10.000000000 +0200
|
|
@@ -141,7 +141,7 @@
|
|
: ${code:=${LIBEXECDIR}/@code@}
|
|
|
|
|
|
-PATH=/bin:/usr/bin:${BINDIR}; export PATH
|
|
+PATH=/bin:/usr/bin:${BINDIR}:${PATH}; export PATH
|
|
|
|
: ${PRUNEFS="nfs NFS proc afs proc smbfs autofs iso9660 ncpfs coda devpts ftpfs devfs mfs sysfs shfs"}
|
|
|
|
diff -Naur findutils-4.2.30/xargs/xargs.c findutils-4.2.30_new/xargs/xargs.c
|
|
--- findutils-4.2.30/xargs/xargs.c 2007-02-27 11:21:08.000000000 +0100
|
|
+++ findutils-4.2.30_new/xargs/xargs.c 2007-07-17 19:02:05.000000000 +0200
|
|
@@ -402,7 +402,7 @@
|
|
int show_limits = 0; /* --show-limits */
|
|
int always_run_command = 1;
|
|
char *input_file = "-"; /* "-" is stdin */
|
|
- char *default_cmd = "/bin/echo";
|
|
+ char *default_cmd = "echo";
|
|
int (*read_args) PARAMS ((void)) = read_line;
|
|
void (*act_on_init_result)(void) = noop;
|
|
int env_too_big = 0;
|