guix/gnu/packages/patches/rocclr-5.6.0-enable-gfx800.patch
John Kehayias 15f9870eb3
gnu: rocm: Update to 5.6.0.
Update all of the ROCm packages at the same time as they share a version
number and should be upgraded together, including llvm-for-rocm.

* gnu/packages/llvm.scm (llvm-for-rocm): Update to 5.6.0.
[source]{patches}: Remove unneeded patches (linkdl and remove-isystem-usr-include).
* gnu/packages/rocm.scm (rocm-cmake, roct-thunk-interface): Update
to 5.6.0.
(rocclr-src): Update to 5.6.0.
[source]{patches}: Add enable-gfx800 patch.
(rocm-device-libs):  Update to 5.6.0.
[inputs]: Update style.
(rocm-comgr): Update to 5.6.0.
[inputs]: Remove lld.  Update style.
(rocr-runtime): Update to 5.6.0.
[arguments]: Use gexps.  Remove configure-flags.  Add add-rocm-device-lib-path
phase.
[inputs]: Add libdrm.  Update style.
[native-inputs]: Add pkg-config.  Update style.
(rocm-opencl-runtime): Update to 5.6.0.
[source]{patches}: Remove noopencl patch.
[arguments]{configure-flags}: Add BUILD_ICD=OFF and
FILE_REORG_BACKWARD_COMPATIBILITY=OFF flags.
[inputs]: Add opencl-headers.
(rocminfo): Update to 5.6.0.
[arguments]: Use gexps.  Use search-input-file instead of assoc-ref and which.
(rocm-bandwidth-test): Update to 5.6.0.
[source]{patches}: Add fix-includes patch.
* gnu/packages/patches/rocm-comgr-3.1.0-dependencies.patch,
gnu/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch: Update patches.
* gnu/packages/patches/llvm-roc-4.0.0-remove-isystem-usr-include.patch,
gnu/packages/patches/llvm-roc-5.0.0-linkdl.patch,
gnu/packages/patches/rocm-opencl-runtime-4.3-noopencl.patch: Delete files.
* gnu/packages/patches/rocm-bandwidth-test-5.5.0-fix-includes.patch,
gnu/packages/patches/rocclr-5.6.0-enable-gfx800.patch: New files.
* gnu/local.mk (dist_patch_DATA): Update patches.
2023-07-11 12:21:00 -04:00

17 lines
970 B
Diff

#From xuhuisheng
#at https://github.com/RadeonOpenCompute/ROCm/issues/1659#issuecomment-1041026624
diff --git a/utils/flags.hpp b/utils/flags.hpp
index 8f0228cc..2eaa47c5 100644
--- a/utils/flags.hpp
+++ b/utils/flags.hpp
@@ -245,7 +245,7 @@ release(bool, ROC_SYSTEM_SCOPE_SIGNAL, true, \
"Enable system scope for signals (uses interrupts).") \
release(bool, ROC_SKIP_COPY_SYNC, false, \
"Skips copy syncs if runtime can predict the same engine.") \
-release(bool, ROC_ENABLE_PRE_VEGA, false, \
+release(bool, ROC_ENABLE_PRE_VEGA, true, \
"Enable support of pre-vega ASICs in ROCm path") \
release(bool, HIP_FORCE_QUEUE_PROFILING, false, \
"Force command queue profiling by default") \