guix/gnu/packages/patches/libgeotiff-fix-tests-with-proj-9.3.0.patch
Felix Gruber a042bfcd7e
gnu: libgeotiff: Fix build with proj 9.3.1.
* gnu/packages/geo.scm (libgeotiff): [source]: Add patches to fix build
  with proj 9.3.1.
* gnu/local.mk: Add patch files.
* gnu/packages/patches/libgeotiff-fix-tests-on-i386.patch: New file.
* gnu/packages/patches/libgeotiff-fix-tests-with-proj-9.3.0.patch: New
  file.
* gnu/packages/patches/libgeotiff-fix-tests-with-proj-9.3.1.patch: New
  file.

Change-Id: I5f09e793698b0b137888faa0f595ef06850c6160
Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
2024-02-07 13:41:57 +01:00

52 lines
2.3 KiB
Diff

From 3806fdab4a17f44641a2113faec778e756e2be3d Mon Sep 17 00:00:00 2001
From: Even Rouault <even.rouault@spatialys.com>
Date: Tue, 29 Aug 2023 19:04:25 +0200
Subject: [PATCH] Fix 'make check' to pass with PROJ 9.3 (fixes #89)
---
https://github.com/OSGeo/libgeotiff/pull/90
test/testlistgeo | 16 +++++++++++++---
1 file changed, 13 insertions(+), 3 deletions(-)
diff --git a/test/testlistgeo b/test/testlistgeo
index 9a41e74..48e92eb 100755
--- a/test/testlistgeo
+++ b/test/testlistgeo
@@ -218,14 +218,24 @@ echo "" >>${OUT}
sed "s/ETRS89-extended/ETRS89/g" < ${OUT} > ${OUT}.tmp
mv ${OUT}.tmp ${OUT}
-sed "s/ETRS89-extended/ETRS89/g" < ${TEST_CLI_DIR}/testlistgeo_out.dist > testlistgeo_out.dist.tmp
+sed "s/ETRS89-extended/ETRS89/g" < ${TEST_CLI_DIR}/testlistgeo_out.dist > testlistgeo_out.dist.normalized
+
+sed "s/GCS: 4053\/Unspecified datum based upon the International 1924 Authalic Sphere/GCS: 10346\/NSIDC Authalic Sphere/g" < ${OUT} > ${OUT}.tmp
+mv ${OUT}.tmp ${OUT}
+sed "s/Datum: 6053\/Not specified (based on International 1924 Authalic Sphere)/Datum: 1360\/NSIDC International 1924 Authalic Sphere/g" < ${OUT} > ${OUT}.tmp
+mv ${OUT}.tmp ${OUT}
+
+sed "s/GCS: 4053\/Unspecified datum based upon the International 1924 Authalic Sphere/GCS: 10346\/NSIDC Authalic Sphere/g" < testlistgeo_out.dist.normalized > testlistgeo_out.dist.normalized.tmp
+mv testlistgeo_out.dist.normalized.tmp testlistgeo_out.dist.normalized
+sed "s/Datum: 6053\/Not specified (based on International 1924 Authalic Sphere)/Datum: 1360\/NSIDC International 1924 Authalic Sphere/g" < testlistgeo_out.dist.normalized > testlistgeo_out.dist.normalized.tmp
+mv testlistgeo_out.dist.normalized.tmp testlistgeo_out.dist.normalized
# do 'diff' with distribution results
# after cleaning for avoid spurios result due
# to different build dir
sed -e "s/Testing listgeo .*test/Testing listgeo ..\/test/" -i ${OUT}
echo "diff ${OUT} with testlistgeo_out.dist"
-diff -u ${OUT} testlistgeo_out.dist.tmp
+diff -u ${OUT} testlistgeo_out.dist.normalized
if [ $? -ne 0 ] ; then
echo ""
echo "PROBLEMS HAVE OCCURRED"
@@ -236,7 +246,7 @@ else
echo "TEST OK"
echo "test file ${OUT} removed"
echo
- rm testlistgeo_out.dist.tmp
+ rm testlistgeo_out.dist.normalized
/bin/rm -f ${OUT}
exit 0
fi