guix/gnu/packages/patches/tootle-glib-object-naming.patch
Taiju HIGASHI b0d25a7118
gnu: tootle: Fix build.
* gnu/packages/patches/tootle-glib-object-naming.patch,
gnu/packages/patches/tootle-reason-phrase.patch: New files.
* gnu/local.mk (dist_patch_DATA): Add them.
* gnu/packages/mastodon.scm (tootle)[source]: Use them.
[inputs]: Use LIBSOUP-MINIMAL-2 instead of LIBSOUP.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
2022-01-05 23:44:18 +01:00

67 lines
2.4 KiB
Diff

From 0816105028c26965e37c9afc7c598854f3fecde1 Mon Sep 17 00:00:00 2001
From: Clayton Craft <clayton@craftyguy.net>
Date: Tue, 26 Oct 2021 15:03:25 -0700
Subject: [PATCH] Adhere to GLib.Object naming conventions for properties
Vala now validates property names against GLib.Object conventions, this
fixes a compilation error as a result of this enforcement:
../src/API/Status.vala:27.5-27.23: error: Name `_url' is not valid for a GLib.Object property
public string? _url { get; set; }
^^^^^^^^^^^^^^^^^^^
Relevant Vala change:
https://gitlab.gnome.org/GNOME/vala/-/commit/38d61fbff037687ea4772e6df85c7e22a74b335e
fixes #337
Signed-off-by: Clayton Craft <clayton@craftyguy.net>
---
src/API/Attachment.vala | 6 +++---
src/API/Status.vala | 8 ++++----
2 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/src/API/Attachment.vala b/src/API/Attachment.vala
index 88bc5bb..35c4018 100644
--- a/src/API/Attachment.vala
+++ b/src/API/Attachment.vala
@@ -4,10 +4,10 @@ public class Tootle.API.Attachment : Entity, Widgetizable {
public string kind { get; set; default = "unknown"; }
public string url { get; set; }
public string? description { get; set; }
- public string? _preview_url { get; set; }
+ private string? t_preview_url { get; set; }
public string? preview_url {
- set { this._preview_url = value; }
- get { return (this._preview_url == null || this._preview_url == "") ? url : _preview_url; }
+ set { this.t_preview_url = value; }
+ get { return (this.t_preview_url == null || this.t_preview_url == "") ? url : t_preview_url; }
}
public File? source_file { get; set; }
diff --git a/src/API/Status.vala b/src/API/Status.vala
index 4f92cdb..00e8a9f 100644
--- a/src/API/Status.vala
+++ b/src/API/Status.vala
@@ -28,16 +28,16 @@ public class Tootle.API.Status : Entity, Widgetizable {
public ArrayList<API.Mention>? mentions { get; set; default = null; }
public ArrayList<API.Attachment>? media_attachments { get; set; default = null; }
- public string? _url { get; set; }
+ private string? t_url { get; set; }
public string url {
owned get { return this.get_modified_url (); }
- set { this._url = value; }
+ set { this.t_url = value; }
}
string get_modified_url () {
- if (this._url == null) {
+ if (this.t_url == null) {
return this.uri.replace ("/activity", "");
}
- return this._url;
+ return this.t_url;
}
public Status formal {