guix/gnu/packages/patches/emacs27-exec-path.patch
Amin Bandali 92d2205a19
gnu: Add emacs-next.
Add `emacs-next' for building latest Emacs from git.

* gnu/packages/emacs.scm (emacs-next): New variable.
(emacs): make the autoload deletion snippet not fail when eshell/esh-groups.el
does not exist.  This enables reuse of the entire snippet field of `emacs' for
`emacs-next'.
* gnu/packages/patches/emacs27-exec-path.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add the above patch file to it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2019-12-23 19:38:14 +01:00

19 lines
811 B
Diff

Do not capture the build-time value of $PATH in the 'emacs' executable
since this can noticeably increase the size of the closure of Emacs
with things like GCC being referenced.
(like emacs-exec-path.patch, but for Emacs 27)
--- a/lisp/loadup.el
+++ b/lisp/loadup.el
@@ -479,7 +479,8 @@ lost after dumping")))
((equal dump-mode "dump") "emacs")
((equal dump-mode "bootstrap") "emacs")
((equal dump-mode "pbootstrap") "bootstrap-emacs.pdmp")
- (t (error "unrecognized dump mode %s" dump-mode)))))
+ (t (error "unrecognized dump mode %s" dump-mode))))
+ (exec-path nil))
(message "Dumping under the name %s" output)
(condition-case ()
(delete-file output)