guix/gnu/packages/patches/guix-test-networking.patch
Ludovic Courtès 8a43ff101e gnu: guix: Upgrade to 0.5.
* gnu/packages/package-management.scm (guix): Upgrade to 0.5.  Update
  the bootstrap binaries; add mips64el; add
  'guix-test-networking.patch'.
2013-12-11 13:55:17 +01:00

16 lines
509 B
Diff

Skip that test when the network is unreachable.
diff --git a/tests/packages.scm b/tests/packages.scm
index 04e3b0b..6ac215b 100644
--- a/tests/packages.scm
+++ b/tests/packages.scm
@@ -139,6 +139,8 @@
(and (direct-store-path? source)
(string-suffix? "utils.scm" source))))
+(unless (false-if-exception (getaddrinfo "www.gnu.org" "80" AI_NUMERICSERV))
+ (test-skip 1))
(test-equal "package-source-derivation, snippet"
"OK"
(let* ((file (search-bootstrap-binary "guile-2.0.9.tar.xz"