c3499ad6b8
* gnu/packages/patches/icecat-CVE-2015-4477.patch, gnu/packages/patches/icecat-CVE-2015-7207.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt01.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt02.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt03.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt04.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt05.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt06.patch, gnu/packages/patches/icecat-CVE-2016-1954.patch, gnu/packages/patches/icecat-CVE-2016-1960.patch, gnu/packages/patches/icecat-CVE-2016-1961.patch, gnu/packages/patches/icecat-CVE-2016-1962.patch, gnu/packages/patches/icecat-CVE-2016-1964.patch, gnu/packages/patches/icecat-CVE-2016-1965.patch, gnu/packages/patches/icecat-CVE-2016-1966.patch, gnu/packages/patches/icecat-CVE-2016-1974.patch, gnu/packages/patches/icecat-bug-1248851.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
44 lines
1.1 KiB
Diff
44 lines
1.1 KiB
Diff
Copied from upstream:
|
|
https://hg.mozilla.org/releases/mozilla-esr38/raw-rev/b4467681abd6
|
|
|
|
# HG changeset patch
|
|
# User Gijs Kruitbosch <gijskruitbosch@gmail.com>
|
|
# Date 1455276061 0
|
|
# Node ID b4467681abd676cd5575cbdf922927f8f54d2ad9
|
|
# Parent 8c1d40e45a72c6432e879137a0afa519dc6c9841
|
|
Bug 1245264 - r=bz, r=ritu
|
|
|
|
MozReview-Commit-ID: I0sVdritpD3
|
|
|
|
diff --git a/dom/base/nsLocation.cpp b/dom/base/nsLocation.cpp
|
|
--- a/dom/base/nsLocation.cpp
|
|
+++ b/dom/base/nsLocation.cpp
|
|
@@ -735,16 +735,27 @@ nsLocation::SetProtocol(const nsAString&
|
|
return rv;
|
|
}
|
|
|
|
rv = uri->SetScheme(NS_ConvertUTF16toUTF8(aProtocol));
|
|
if (NS_WARN_IF(NS_FAILED(rv))) {
|
|
return rv;
|
|
}
|
|
|
|
+ nsAutoCString newSpec;
|
|
+ rv = uri->GetSpec(newSpec);
|
|
+ if (NS_FAILED(rv)) {
|
|
+ return rv;
|
|
+ }
|
|
+ // We may want a new URI class for the new URI, so recreate it:
|
|
+ rv = NS_NewURI(getter_AddRefs(uri), newSpec);
|
|
+ if (NS_FAILED(rv)) {
|
|
+ return rv;
|
|
+ }
|
|
+
|
|
return SetURI(uri);
|
|
}
|
|
|
|
void
|
|
nsLocation::GetUsername(nsAString& aUsername, ErrorResult& aError)
|
|
{
|
|
if (!CallerSubsumes()) {
|
|
aError.Throw(NS_ERROR_DOM_SECURITY_ERR);
|
|
|