c3499ad6b8
* gnu/packages/patches/icecat-CVE-2015-4477.patch, gnu/packages/patches/icecat-CVE-2015-7207.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt01.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt02.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt03.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt04.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt05.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt06.patch, gnu/packages/patches/icecat-CVE-2016-1954.patch, gnu/packages/patches/icecat-CVE-2016-1960.patch, gnu/packages/patches/icecat-CVE-2016-1961.patch, gnu/packages/patches/icecat-CVE-2016-1962.patch, gnu/packages/patches/icecat-CVE-2016-1964.patch, gnu/packages/patches/icecat-CVE-2016-1965.patch, gnu/packages/patches/icecat-CVE-2016-1966.patch, gnu/packages/patches/icecat-CVE-2016-1974.patch, gnu/packages/patches/icecat-bug-1248851.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
33 lines
1.2 KiB
Diff
33 lines
1.2 KiB
Diff
Copied from upstream:
|
|
https://hg.mozilla.org/releases/mozilla-esr38/raw-rev/e93aeb25e2a4
|
|
|
|
# HG changeset patch
|
|
# User Andrew McCreight <continuation@gmail.com>
|
|
# Date 1455891967 28800
|
|
# Node ID e93aeb25e2a44df8d22f5a065b4410620e2c8730
|
|
# Parent 221de852fda32714a9e484774ceafafb450ea73c
|
|
Bug 1249377 - Hold a strong reference to |root| in nsHTMLDocument::SetBody. r=bz, a=sylvestre
|
|
|
|
diff --git a/dom/html/nsHTMLDocument.cpp b/dom/html/nsHTMLDocument.cpp
|
|
--- a/dom/html/nsHTMLDocument.cpp
|
|
+++ b/dom/html/nsHTMLDocument.cpp
|
|
@@ -1044,17 +1044,17 @@ nsHTMLDocument::SetBody(nsIDOMHTMLElemen
|
|
ErrorResult rv;
|
|
SetBody(static_cast<nsGenericHTMLElement*>(newBody.get()), rv);
|
|
return rv.ErrorCode();
|
|
}
|
|
|
|
void
|
|
nsHTMLDocument::SetBody(nsGenericHTMLElement* newBody, ErrorResult& rv)
|
|
{
|
|
- Element* root = GetRootElement();
|
|
+ nsCOMPtr<Element> root = GetRootElement();
|
|
|
|
// The body element must be either a body tag or a frameset tag. And we must
|
|
// have a html root tag, otherwise GetBody will not return the newly set
|
|
// body.
|
|
if (!newBody || !(newBody->Tag() == nsGkAtoms::body ||
|
|
newBody->Tag() == nsGkAtoms::frameset) ||
|
|
!root || !root->IsHTML() ||
|
|
root->Tag() != nsGkAtoms::html) {
|
|
|