be9b7e0f65
* gnu/packages/patches/xpra-4.2-install_libs.patch: Move to ... * gnu/packages/patches/xpra-5.0-install_libs.patch: ... this file. * gnu/packages/patches/xpra-4.2-systemd-run.patch: Move to ... * gnu/packages/patches/xpra-5.0-systemd-run.patch: ... this file. * gnu/local.mk (dist_patch_DATA): Update accordingly. * gnu/packages/xorg.scm (xpra): Update to 5.0.2. [source] <patches>: Rename per version changes [inputs]: Add cups. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
48 lines
1.4 KiB
Diff
48 lines
1.4 KiB
Diff
Distriction specific patch, not going upstream
|
|
|
|
Disable systemd-run if the command is not found.
|
|
|
|
diff --git a/xpra/scripts/main.py b/xpra/scripts/main.py
|
|
index 3813331a5..46e2c83a6 100755
|
|
--- a/xpra/scripts/main.py
|
|
+++ b/xpra/scripts/main.py
|
|
@@ -337,23 +337,26 @@ def use_systemd_run(s) -> bool:
|
|
cmd = ["systemd-run", "--quiet"]
|
|
if getuid()!=0:
|
|
cmd += ["--user"]
|
|
- cmd += ["--scope", "--", "true"]
|
|
- proc = Popen(cmd, stdout=PIPE, stderr=PIPE, shell=False)
|
|
try:
|
|
- proc.communicate(timeout=2)
|
|
- r = proc.returncode
|
|
- except TimeoutExpired: # pragma: no cover
|
|
- r = None
|
|
- if r is None:
|
|
- try:
|
|
- proc.terminate()
|
|
- except Exception:
|
|
- pass
|
|
+ cmd = ["systemd-run", "--quiet", "--user", "--scope", "--", "true"]
|
|
+ proc = Popen(cmd, stdout=PIPE, stderr=PIPE, shell=False)
|
|
try:
|
|
- proc.communicate(timeout=1)
|
|
+ proc.communicate(timeout=2)
|
|
+ r = proc.returncode
|
|
except TimeoutExpired: # pragma: no cover
|
|
r = None
|
|
- return r==0
|
|
+ if r is None:
|
|
+ try:
|
|
+ proc.terminate()
|
|
+ except Exception:
|
|
+ pass
|
|
+ try:
|
|
+ proc.communicate(timeout=1)
|
|
+ except TimeoutExpired: # pragma: no cover
|
|
+ r = None
|
|
+ return r==0
|
|
+ except FileNotFoundError:
|
|
+ return False
|
|
|
|
def verify_gir():
|
|
try:
|