guix/gnu/packages/patches/u-boot-fix-u-boot-lib-build.patch
Maxim Cournoyer ffbcc113df
gnu: Add python-u-boot-pylib.
* gnu/packages/bootloaders.scm (python-u-boot-pylib): New variable.
* gnu/packages/patches/u-boot-fix-u-boot-lib-build.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Register it.

Signed-off-by: Vagrant Cascadian <vagrant@debian.org>
2023-07-19 22:54:34 -07:00

25 lines
784 B
Diff

Submitted upstream (see:
https://lists.denx.de/pipermail/u-boot/2023-July/521984.html)
diff --git a/tools/u_boot_pylib/pyproject.toml b/tools/u_boot_pylib/pyproject.toml
index 3f33caf6f8..037c5d629e 100644
--- a/tools/u_boot_pylib/pyproject.toml
+++ b/tools/u_boot_pylib/pyproject.toml
@@ -9,7 +9,7 @@ authors = [
{ name="Simon Glass", email="sjg@chromium.org" },
]
description = "U-Boot python library"
-readme = "README.md"
+readme = "README.rst"
requires-python = ">=3.7"
classifiers = [
"Programming Language :: Python :: 3",
@@ -20,3 +20,7 @@ classifiers = [
[project.urls]
"Homepage" = "https://u-boot.readthedocs.io"
"Bug Tracker" = "https://source.denx.de/groups/u-boot/-/issues"
+
+[tool.setuptools.packages.find]
+where = [".."]
+include = ["u_boot_pylib*"]