guix/gnu/packages/patches/swig-support-gcc-12.patch
Greg Hogan 35db5d5ca4
gnu: swig: Fix build with GCC-12.
* gnu/packages/patches/swig-support-gcc-12.patch: New file.
* gnu/local.mk: Add it.
* gnu/packages/swig.scm (swig)[source]: Add patch.

Signed-off-by: Marius Bakke <marius@gnu.org>
2022-09-01 23:37:13 +02:00

17 lines
785 B
Diff

Fix for https://github.com/swig/swig/issues/2145 made in unreleased upstream commit
https://github.com/swig/swig/commit/76d5a9ec270a763c892ae28070e391cf99e0b7cd
diff --git a/Examples/test-suite/nested_class.i b/Examples/test-suite/nested_class.i
index b10c339493e..c778a12cf7c 100644
--- a/Examples/test-suite/nested_class.i
+++ b/Examples/test-suite/nested_class.i
@@ -201,7 +201,7 @@ struct Outer {
Integer xx;
} MultipleInstanceAnonDerived1, MultipleInstanceAnonDerived2, *MultipleInstanceAnonDerived3, MultipleInstanceAnonDerived4[2];
-#if defined(__GNUC__) || defined(_MSC_VER) || defined(SWIG)
+#if (defined(__GNUC__) && __GNUC__ < 12) || defined(_MSC_VER) || defined(SWIG)
/* some compilers do not accept these */
struct : public InnerMultiple {
Integer xx;