guix/gnu/packages/patches/scribus-1.5.8-poppler-22.09.0.patch
Ricardo Wurmus 8495069bed
gnu: scribus: Fix build with latest poppler.
* gnu/packages/patches/scribus-1.5.8-poppler-22.03.0.patch,
gnu/packages/patches/scribus-1.5.8-poppler-22.04.0.patch,
gnu/packages/patches/scribus-1.5.8-poppler-22.09.0.patch,
gnu/packages/patches/scribus-1.5.8-poppler-22.2.0-1.patch,
gnu/packages/patches/scribus-1.5.8-poppler-22.2.0-2.patch: New files.
* gnu/local.mk (dist_patch_DATA): Add them.
* gnu/packages/scribus.scm (scribus)[source]: Add patches.
[arguments]: Enable WANT_CPP17 option.
2023-04-25 06:17:16 +02:00

21 lines
677 B
Diff

--- a/scribus/plugins/import/pdf/slaoutput.cpp
+++ b/scribus/plugins/import/pdf/slaoutput.cpp
@@ -3741,9 +3741,16 @@ void SlaOutputDev::getPenState(GfxState *state)
break;
}
double lw = state->getLineWidth();
- double *dashPattern;
int dashLength;
+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(22, 9, 0)
+ const double *dashPattern;
+ const std::vector<double> &dash = state->getLineDash(&DashOffset);
+ dashPattern = dash.data();
+ dashLength = dash.size();
+#else
+ double *dashPattern;
state->getLineDash(&dashPattern, &dashLength, &DashOffset);
+#endif
QVector<double> pattern(dashLength);
for (int i = 0; i < dashLength; ++i)
{