guix/gnu/packages/patches/python-peachpy-determinism.patch
Ludovic Courtès b87fe805aa
gnu: python-peachpy: Make output deterministic.
Fixes <https://issues.guix.gnu.org/50672>.

This makes users of python-peachpy bit-reproducible, such as nnpack.

* gnu/packages/patches/python-peachpy-determinism.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/python-xyz.scm (python-peachpy)[source]: Use it.

Co-authored-by: Kyle Meyer <kyle@kyleam.com>
2021-10-25 14:32:59 +02:00

26 lines
1 KiB
Diff

Make PeachPy processes deterministic:
https://github.com/Maratyszcza/PeachPy/issues/88
https://issues.guix.gnu.org/50672
diff --git a/peachpy/name.py b/peachpy/name.py
index b6a03dc..412079d 100644
--- a/peachpy/name.py
+++ b/peachpy/name.py
@@ -86,13 +86,13 @@ def add_scoped_name(self, scoped_name):
self.names[scope_name.name] = scope
else:
assert scope_name.name is None
- self.prenames.setdefault(scope_name.prename, set())
+ self.prenames.setdefault(scope_name.prename, {})
if subscoped_name:
for subscope in iter(self.prenames[scope_name.prename]):
if isinstance(subscope, Namespace) and subscope.scope_name is scope_name:
subscope.add_scoped_name(subscoped_name)
return
- self.prenames[scope_name.prename].add(scope)
+ self.prenames[scope_name.prename][scope] = None
def assign_names(self):
# Step 1: assign names to symbols with prenames with no conflicts