guix/gnu/packages/patches/gnumach-support-noide.patch
Janneke Nieuwenhuizen bbfb41ed9d
gnu: gnumach: Support "noide" argument.
* gnu/packages/patches/gnumach-support-noide.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/hurd.scm (gnumach-headers): Use it.
* doc/guix.texi (Bootloader Configuration): Document it.

Signed-off-by: Josselin Poiret <dev@jpoiret.xyz>
2023-07-13 18:59:17 +02:00

26 lines
685 B
Diff

Upstream status: Taken from Debian/upsream.
https://salsa.debian.org/hurd-team/gnumach/-/blob/master/debian/patches/90_noide.patch
This supports using `noide' on the gnumach command line, disabling
gnumach IDE support and thus forcing use of rumdisk.
---
linux/dev/glue/block.c | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
--- a/linux/dev/glue/block.c
+++ b/linux/dev/glue/block.c
@@ -207,7 +207,10 @@ int
blk_dev_init ()
{
#ifdef CONFIG_BLK_DEV_IDE
- ide_init ();
+ extern char *kernel_cmdline;
+ if (strncmp(kernel_cmdline, "noide", 5) &&
+ !strstr(kernel_cmdline, " noide"))
+ ide_init ();
#endif
#ifdef CONFIG_BLK_DEV_FD
floppy_init ();