guix/gnu/packages/patches/ruby-hydra-minimal-no-byebug.patch
Ludovic Courtès 7a485d43c9
gnu: ruby-hydra-minimal: Add missing patch.
This is a followup to bb907402a6.

* gnu/packages/patches/ruby-hydra-minimal-no-byebug.patch: New file.
2022-08-08 18:33:10 +02:00

12 lines
335 B
Diff

Description: Avoid dependency on byebug to reduce package closure
significantly, see https://issues.guix.gnu.org/55997
diff --git a/lib/hydra.rb b/lib/hydra.rb
index 29fbad2..6b5058a 100644
--- a/lib/hydra.rb
+++ b/lib/hydra.rb
@@ -1,4 +1,3 @@
-require 'byebug' unless ENV['RACK_ENV'] == "production"
require 'pp'
module CoreExt